aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-06-07 22:07:30 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-06-10 22:57:01 +0800
commitaf09dabf70659a891bc1cb392aeff1ff5b8aeded (patch)
tree068a42d9a149724dd38faa30827678f61f5409d6
parent4dd1fb79f7a3247f92989df6d14ccc71737cd172 (diff)
downloadguix-af09dabf70659a891bc1cb392aeff1ff5b8aeded.tar
guix-af09dabf70659a891bc1cb392aeff1ff5b8aeded.tar.gz
gnu: Add keepalived.
* gnu/packages/cluster.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/cluster.scm67
2 files changed, 68 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 6aba6433fb..7fa7e7d818 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -96,6 +96,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/chez.scm \
%D%/packages/ci.scm \
%D%/packages/cinnamon.scm \
+ %D%/packages/cluster.scm \
%D%/packages/cmake.scm \
%D%/packages/cobol.scm \
%D%/packages/code.scm \
diff --git a/gnu/packages/cluster.scm b/gnu/packages/cluster.scm
new file mode 100644
index 0000000000..429b0885a0
--- /dev/null
+++ b/gnu/packages/cluster.scm
@@ -0,0 +1,67 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cluster)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages tls))
+
+(define-public keepalived
+ (package
+ (name "keepalived")
+ (version "2.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.keepalived.org/software/keepalived-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0hp8i56zkf0398bmpi32a85f05cv2fy9wizkdfbxk7gav4z6yx18"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-configure
+ (lambda _
+ ;; XXX: The 'configure' script doesn't handle '-L' flags in the
+ ;; output of 'pkg-config'.
+ (substitute* "configure"
+ (("PKG_CONFIG --libs") "PKG_CONFIG --libs-only-l"))
+ #t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python-sphinx" ,python-sphinx)))
+ (inputs
+ `(("openssl" ,openssl)
+ ("libnfnetlink" ,libnfnetlink)
+ ("libnl" ,libnl)))
+ (home-page "http://www.keepalived.org/")
+ (synopsis "Loadbalancing and high-availability frameworks")
+ (description
+ "Keepalived provides frameworks for both load balancing and high
+availability. The load balancing framework relies on the Linux Virtual
+Server (IPVS) kernel module. High availability is achieved by the Virtual
+Redundancy Routing Protocol (VRRP). Each Keepalived framework can be used
+independently or together to provide resilient infrastructures.")
+ (license license:gpl2+)))