aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-01 09:56:02 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-11 15:19:02 +0200
commit8bf7f741e99715c3104718304c82fc15adecc260 (patch)
tree0d65222f3aedb0cea055a9351c7484c7b6179eb9
parent50a1f9264d78487965bbb38a391470914d3122f7 (diff)
downloadguix-8bf7f741e99715c3104718304c82fc15adecc260.tar
guix-8bf7f741e99715c3104718304c82fc15adecc260.tar.gz
gnu: Add Add emacs-wgrep-helm.
* gnu/packages/emacs.scm (emacs-wgrep-helm): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 75b4213f75..9caa01a0fd 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11201,3 +11201,30 @@ e.g. the package dependencies it requires. See function
\"Package-Requires:\" or \"Package-Version:\" header is present in the
file.")
(license license:gpl3+))))
+
+(define-public emacs-wgrep-helm
+ (let ((commit "1cdd7c136f1e7565bb13d2df69be3dc77b83698d"))
+ (package
+ (name "emacs-wgrep-helm")
+ (version (git-version "2.1.10" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mhayashi1120/Emacs-wgrep")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "057p99hq0r6z1k8sl15w3sxrqvlv0g9wp39zy1pqhccv2mn3g2d6"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-wgrep" ,emacs-wgrep)))
+ (home-page
+ "https://github.com/mhayashi1120/Emacs-wgrep")
+ (synopsis
+ "Writable helm-grep-mode buffer and apply the changes to files")
+ (description
+ "@code{wgrep-helm} allows you to edit a @code{helm-grep-mode} buffer and
+apply those changes to the file buffer.")
+ (license license:gpl3+))))