aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-01 09:52:39 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-08 17:04:23 +0200
commit5a949f5b30b5ada0cca99beb69020c86899e1827 (patch)
tree06cd82e76f5b045a1637e8050fb367ce421f4e07
parent0b4e4efe972d808db1a9eba04822d9da9d5887c6 (diff)
downloadguix-5a949f5b30b5ada0cca99beb69020c86899e1827.tar
guix-5a949f5b30b5ada0cca99beb69020c86899e1827.tar.gz
gnu: Add emacs-helm-emms.
* gnu/packages/emacs.scm (emacs-helm-emms): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d4fda8e663..be3c8f3715 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10940,3 +10940,29 @@ type @code{C-h b}, or any incomplete key sequence plus @code{C-h}, to run
@code{describe-bindings} does, but you can use completion to find the command
you searched for and execute it, or view its documentation.")
(license license:gpl3+))))
+
+(define-public emacs-helm-emms
+ (let ((commit "d3f9bdef8ff0d093eaf6e26af50ea905ab53fdec"))
+ (package
+ (name "emacs-helm-emms")
+ (version (git-version "1.3" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-helm/helm-emms")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0bdb8xp0yp3gijpa9i2rc17gfzjhzlm92vdzw93i10qpd1xhj4aa"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)
+ ("emacs-emms" ,emms)))
+ (home-page
+ "https://github.com/emacs-helm/helm-emms")
+ (synopsis "Emms for Helm")
+ (description "Helm interface for Emms to browse all tracks and all folders
+from @code{emms-source-file-default-directory}.")
+ (license license:gpl3+))))