aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-05-28 22:14:04 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-06-09 23:25:24 +0200
commit18736663edf3bd5dfb69b2f3e282af40f80d7143 (patch)
tree7385522b5cfa835d0788566b0c532e2637020adf
parent90fe8797cda18b123a1b28c9cad7c03673afe5dd (diff)
downloadguix-18736663edf3bd5dfb69b2f3e282af40f80d7143.tar
guix-18736663edf3bd5dfb69b2f3e282af40f80d7143.tar.gz
gnu: Add maven-repository-metadata.
* gnu/packages/maven.scm (maven-repository-metadata): New variable.
-rw-r--r--gnu/packages/maven.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index 649c9f962b..fe9554146e 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -439,3 +439,49 @@ inheritance, interpolation, @dots{}")))
(description "Apache Maven is a software project management and comprehension
tool. This package contains the effective model builder, with profile activation,
inheritance, interpolation, @dots{}")))
+
+(define-public maven-repository-metadata
+ (package
+ (inherit maven-artifact)
+ (name "maven-repository-metadata")
+ (arguments
+ `(#:jar-name "maven-repository-metadata.jar"
+ #:source-dir "maven-repository-metadata/src/main/java"
+ #:jdk ,icedtea-8
+ #:tests? #f; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'generate-models
+ (lambda* (#:key inputs #:allow-other-keys)
+ (define (modello-single-mode file version mode)
+ (invoke "java" "org.codehaus.modello.ModelloCli"
+ file mode "maven-repository-metadata/src/main/java" version
+ "false" "true"))
+ (let ((file "maven-repository-metadata/src/main/mdo/metadata.mdo"))
+ (modello-single-mode file "1.1.0" "java")
+ (modello-single-mode file "1.1.0" "xpp3-reader")
+ (modello-single-mode file "1.1.0" "xpp3-writer"))
+ #t)))))
+ (inputs '())
+ (native-inputs
+ `(("modello" ,java-modello-core)
+ ;; for modello:
+ ("java-eclipse-sisu-plexus" ,java-eclipse-sisu-plexus)
+ ("java-plexus-component-annotations" ,java-plexus-component-annotations)
+ ("java-guice" ,java-guice)
+ ("java-cglib" ,java-cglib)
+ ("java-asm" ,java-asm)
+ ("java-eclipse-sisu-inject" ,java-eclipse-sisu-inject)
+ ("java-javax-inject" ,java-javax-inject)
+ ("java-plexus-utils" ,java-plexus-utils)
+ ("java-plexus-classworlds" ,java-plexus-classworlds)
+ ("java-guava" ,java-guava)
+ ("java-geronimo-xbean-reflect" ,java-geronimo-xbean-reflect)
+ ("java-sisu-build-api" ,java-sisu-build-api)
+ ;; modello plugins:
+ ("java-modello-plugins-java" ,java-modello-plugins-java)
+ ("java-modello-plugins-xml" ,java-modello-plugins-xml)
+ ("java-modello-plugins-xpp3" ,java-modello-plugins-xpp3)))
+ (description "Apache Maven is a software project management and comprehension
+tool. This package contains strictly the model for Maven Repository Metadata,
+so really just plain objects.")))