aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-01 09:52:15 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-08 17:04:23 +0200
commit0b4e4efe972d808db1a9eba04822d9da9d5887c6 (patch)
tree8fa4dfe690ff3b9a0e35d3df071f477915bc4481
parent3540c6eb2b51f98f0243170ce55b4ec3eede0983 (diff)
downloadguix-0b4e4efe972d808db1a9eba04822d9da9d5887c6.tar
guix-0b4e4efe972d808db1a9eba04822d9da9d5887c6.tar.gz
gnu: Add emacs-helm-descbinds.
* gnu/packages/emacs.scm (emacs-helm-descbinds): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 96bb8cbc9d..d4fda8e663 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10912,3 +10912,31 @@ on-line service.")
"This is a Helm interface to company-mode, a text completion
framework.")
(license license:gpl3+))))
+
+(define-public emacs-helm-descbinds
+ (let ((commit "033be73f21778633813264ce1634a6e1ad873d8e"))
+ (package
+ (name "emacs-helm-descbinds")
+ (version (git-version "1.13" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-helm/helm-descbinds")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1n89p56qwa243w1c85i5awnaf7piwjsvfi7nmnsrwm33hix5dknk"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-helm" ,emacs-helm)))
+ (home-page "https://github.com/emacs-helm/helm-descbinds")
+ (synopsis "Convenient @code{describe-bindings} with Helm")
+ (description
+ "This package is a replacement of @code{describe-bindings} for Helm.
+@code{describe-bindings} is replaced with @code{helm-descbinds}. As usual,
+type @code{C-h b}, or any incomplete key sequence plus @code{C-h}, to run
+@code{helm-descbinds}. The bindings are presented in a similar way as
+@code{describe-bindings} does, but you can use completion to find the command
+you searched for and execute it, or view its documentation.")
+ (license license:gpl3+))))