aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2017-08-11 19:56:28 +0300
committerManolis Ragkousis <manolis837@gmail.com>2017-08-17 19:35:28 +0300
commit42d0d13de841b424fc3a8ec6d0c2f2835757a615 (patch)
tree6dcbf9a6217666e32b4925b1b90e37983d3de483
parentdd75a9a22c7983af281f605b9b08cf7152796a24 (diff)
downloadguix-42d0d13de841b424fc3a8ec6d0c2f2835757a615.tar
guix-42d0d13de841b424fc3a8ec6d0c2f2835757a615.tar.gz
gnu: Add mygui.
* gnu/packages/game-development.scm (mygui): New variable.
-rw-r--r--gnu/packages/game-development.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index c98c15e462..13e26c04ff 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 Julian Graham <joolean@gmail.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,11 +41,14 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnunet)
+ #:use-module (gnu packages graphics)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages guile)
#:use-module (gnu packages m4)
#:use-module (gnu packages multiprecision)
@@ -934,3 +938,43 @@ Joysticks, etc) and feedback devices (e.g. force feedback). Meant to be very
robust and compatible with many systems and operating systems.")
(home-page "https://github.com/wgois/OIS")
(license license:zlib)))
+
+(define-public mygui
+ (package
+ (name "mygui")
+ (version "3.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/MyGUI/" name
+ "/archive/MyGUI" version ".tar.gz"))
+ (sha256
+ (base32
+ "13x7cydmj7gjmsg702sqjbfi53z265iv6j7binv3r6a7ibndfa0a"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; No test target
+ #:configure-flags
+ (list "-DMYGUI_INSTALL_DOCS=TRUE"
+ (string-append "-DOGRE_INCLUDE_DIR="
+ (assoc-ref %build-inputs "ogre")
+ "/include/OGRE"))))
+ (native-inputs
+ `(("boost" ,boost)
+ ("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("font-dejavu" ,font-dejavu)
+ ("freetype" ,freetype)
+ ("graphviz" ,graphviz)
+ ("libx11" ,libx11)
+ ("ogre" ,ogre)
+ ("ois" ,ois)))
+ (synopsis "Fast, flexible and simple GUI")
+ (description
+ "MyGUI is a library for creating Graphical User Interfaces (GUIs) for games
+and 3D applications. The main goals of mygui are: speed, flexibility and ease
+of use.")
+ (home-page "http://mygui.info/")
+ (license license:expat)))