aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-14 11:10:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-15 06:36:04 +0300
commited8cdab8708d0df31020feb0b7b63e55516ee129 (patch)
tree1d6fa25b373c81e84e6b6d8dee2682fbaec0a67e
parentf51d01e1c3c164e63ace62060a0791de09e0ab58 (diff)
downloadguix-ed8cdab8708d0df31020feb0b7b63e55516ee129.tar
guix-ed8cdab8708d0df31020feb0b7b63e55516ee129.tar.gz
gnu: Add gcc-objc++@5.
* gnu/packages/gcc.scm (gcc-objc++@5): New variable.
-rw-r--r--gnu/packages/gcc.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 563c53f388..7c19a330ab 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -623,6 +623,15 @@ as the 'native-search-paths' field."
(variable "LIBRARY_PATH")
(files '("lib" "lib64"))))))
+(define-public gcc-objc++-5
+ (custom-gcc gcc-5 "gcc-objc++" '("obj-c++")
+ (list (search-path-specification
+ (variable "OBJCPLUS_INCLUDE_PATH")
+ (files '("include")))
+ (search-path-specification
+ (variable "LIBRARY_PATH")
+ (files '("lib" "lib64"))))))
+
(define-public gcc-objc++ gcc-objc++-4.9)
(define (make-libstdc++-doc gcc)