aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-12 20:55:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-13 08:55:42 +0300
commitdd4efefdb0dc3240cd394a79f648cd9b171e83c0 (patch)
treec544769b5d1c4b35d4e31ca19bd4944193c8e2e5
parent3f9a4eaf92c7a4197ce3a23ee8ac5968f80b6431 (diff)
downloadguix-dd4efefdb0dc3240cd394a79f648cd9b171e83c0.tar
guix-dd4efefdb0dc3240cd394a79f648cd9b171e83c0.tar.gz
gnu: gcc@4.9: Inherit from gcc@4.8.
* gnu/packages/gcc.scm (gcc@4.9)[inherit]: Inherit from gcc@4.8. [supported-systems]: Remove field.
-rw-r--r--gnu/packages/gcc.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index da4d66ce36..6c7f13ea47 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -357,7 +357,7 @@ Go. It also includes runtime support libraries for these languages.")
(supported-systems %supported-systems)))
(define-public gcc-4.9
- (package (inherit gcc-4.7)
+ (package (inherit gcc-4.8)
(version "4.9.4")
(source (origin
(method url-fetch)
@@ -368,8 +368,7 @@ Go. It also includes runtime support libraries for these languages.")
"14l06m7nvcvb0igkbip58x59w3nq6315k6jcz3wr9ch1rn9d44bc"))
(patches (search-patches "gcc-arm-bug-71399.patch"
"gcc-libvtv-runpath.patch"))))
- (native-inputs `(("texinfo" ,texinfo)))
- (supported-systems %supported-systems)))
+ (native-inputs `(("texinfo" ,texinfo)))))
(define-public gcc-5
;; Note: GCC >= 5 ships with .info files but 'make install' fails to install