aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-14 11:13:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-15 06:36:15 +0300
commitce9afe2b3b55263d6d02f2e394ea30878fc1e553 (patch)
tree7d58c560350af80fb088b1667848351cad9b2e6f
parent7a7c63085629dfd3c645ecdff43a085f3c2489f2 (diff)
downloadguix-ce9afe2b3b55263d6d02f2e394ea30878fc1e553.tar
guix-ce9afe2b3b55263d6d02f2e394ea30878fc1e553.tar.gz
gnu: Add gcc-objc@7.
* gnu/packages/gcc.scm (gcc-objc@7): New variable.
-rw-r--r--gnu/packages/gcc.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 9f1c7d82ef..453059c8de 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -612,6 +612,15 @@ as the 'native-search-paths' field."
(variable "LIBRARY_PATH")
(files '("lib" "lib64"))))))
+(define-public gcc-objc-7
+ (custom-gcc gcc-7 "gcc-objc" '("objc")
+ (list (search-path-specification
+ (variable "OBJC_INCLUDE_PATH")
+ (files '("include")))
+ (search-path-specification
+ (variable "LIBRARY_PATH")
+ (files '("lib" "lib64"))))))
+
(define-public gcc-objc gcc-objc-4.9)
(define-public gcc-objc++-4.8