aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-08-28 20:56:57 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-12 22:59:37 +0100
commit996364fb4ed6ce18e852341f3be73a2f72cf3a32 (patch)
treef75a07db7ec18487ef25bae1b25c885d6121b589
parent24c1c51334ccee4a6485eb2ab2dc49a2d2ffd02f (diff)
downloadguix-996364fb4ed6ce18e852341f3be73a2f72cf3a32.tar
guix-996364fb4ed6ce18e852341f3be73a2f72cf3a32.tar.gz
gnu: Add perl-text-template.
* gnu/packages/perl.scm (perl-text-template): New variable.
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index aeebd23c21..4463d22fd0 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8013,6 +8013,32 @@ algorism to indicate multiplication by 1000.")
(description "Text::Table renders plaintext tables.")
(license x11)))
+(define-public perl-text-template
+ (package
+ (name "perl-text-template")
+ (version "1.47")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MS/MSCHOUT/Text-Template-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1z781cgz7wbn80lf3kqr2ad0pg6g1wlnim0822h8liw28k3l5msh"))))
+ (build-system perl-build-system)
+ (home-page
+ "http://search.cpan.org/dist/Text-Template")
+ (synopsis
+ "Expand template text with embedded Perl")
+ (description
+ "This is a library for generating letters, building HTML pages, or
+filling in templates generally. A template is a piece of text that has little
+Perl programs embedded in it here and there. When you fill in a template, you
+evaluate the little programs and replace them with their values.")
+ (license perl-license)))
+
(define-public perl-text-unidecode
(package
(name "perl-text-unidecode")