aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-09-14 00:01:21 +0200
committerLudovic Courtès <ludo@gnu.org>2017-09-14 00:10:13 +0200
commit8f3b63b5d73c0b49139c8a20b7576732abfdeeb8 (patch)
treed685f9df83a202ea650399f9e84f155c021d7cef
parent2ed1f4a52d8bec2c18a9c92cf4e7caf93aeb40fc (diff)
downloadguix-8f3b63b5d73c0b49139c8a20b7576732abfdeeb8.tar
guix-8f3b63b5d73c0b49139c8a20b7576732abfdeeb8.tar.gz
uuid: Move tests to 'tests/uuid.scm'.
* tests/file-systems.scm ("uuid->string", "string->uuid") ("uuid", "uuid, syntax error"): Move to... * tests/uuid.scm: ... here. New file. ("uuid, ISO-9660, format preserved"): New test.
-rw-r--r--Makefile.am1
-rw-r--r--tests/file-systems.scm28
-rw-r--r--tests/uuid.scm56
3 files changed, 57 insertions, 28 deletions
diff --git a/Makefile.am b/Makefile.am
index 4c2e77d191..aca18526f7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -312,6 +312,7 @@ SCM_TESTS = \
tests/workers.scm \
tests/zlib.scm \
tests/file-systems.scm \
+ tests/uuid.scm \
tests/system.scm \
tests/services.scm \
tests/scripts-build.scm \
diff --git a/tests/file-systems.scm b/tests/file-systems.scm
index 8e5c75e48c..4c28d0ebc5 100644
--- a/tests/file-systems.scm
+++ b/tests/file-systems.scm
@@ -19,43 +19,15 @@
(define-module (test-file-systems)
#:use-module (guix store)
#:use-module (guix modules)
- #:use-module (gnu system uuid)
#:use-module (gnu system file-systems)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-64)
- #:use-module (rnrs bytevectors)
#:use-module (ice-9 match))
;; Test the (gnu system file-systems) module.
(test-begin "file-systems")
-(test-equal "uuid->string"
- "c5307e6b-d1ba-499d-89c5-cb0b143577c4"
- (uuid->string
- #vu8(197 48 126 107 209 186 73 157 137 197 203 11 20 53 119 196)))
-
-(test-equal "string->uuid"
- '(16 "4dab5feb-d176-45de-b287-9b0a6e4c01cb")
- (let ((uuid (string->uuid "4dab5feb-d176-45de-b287-9b0a6e4c01cb")))
- (list (bytevector-length uuid) (uuid->string uuid))))
-
-(test-assert "uuid"
- (let ((str "4dab5feb-d176-45de-b287-9b0a6e4c01cb"))
- (bytevector=? (uuid-bytevector
- (uuid "4dab5feb-d176-45de-b287-9b0a6e4c01cb"))
- (string->uuid "4dab5feb-d176-45de-b287-9b0a6e4c01cb"))))
-
-(test-assert "uuid, syntax error"
- (catch 'syntax-error
- (lambda ()
- (eval '(uuid "foobar") (current-module))
- #f)
- (lambda (key proc message location form . args)
- (and (eq? proc 'uuid)
- (string-contains message "invalid UUID")
- (equal? form '(uuid "foobar" 'dce))))))
-
(test-assert "file-system-needed-for-boot?"
(let-syntax ((dummy-fs (syntax-rules ()
((_ directory)
diff --git a/tests/uuid.scm b/tests/uuid.scm
new file mode 100644
index 0000000000..c2f15de996
--- /dev/null
+++ b/tests/uuid.scm
@@ -0,0 +1,56 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015, 2017 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-uuid)
+ #:use-module (gnu system uuid)
+ #:use-module (srfi srfi-64)
+ #:use-module (rnrs bytevectors))
+
+(test-begin "uuid")
+
+(test-equal "uuid->string"
+ "c5307e6b-d1ba-499d-89c5-cb0b143577c4"
+ (uuid->string
+ #vu8(197 48 126 107 209 186 73 157 137 197 203 11 20 53 119 196)))
+
+(test-equal "string->uuid"
+ '(16 "4dab5feb-d176-45de-b287-9b0a6e4c01cb")
+ (let ((uuid (string->uuid "4dab5feb-d176-45de-b287-9b0a6e4c01cb")))
+ (list (bytevector-length uuid) (uuid->string uuid))))
+
+(test-assert "uuid"
+ (let ((str "4dab5feb-d176-45de-b287-9b0a6e4c01cb"))
+ (bytevector=? (uuid-bytevector
+ (uuid "4dab5feb-d176-45de-b287-9b0a6e4c01cb"))
+ (string->uuid "4dab5feb-d176-45de-b287-9b0a6e4c01cb"))))
+
+(test-assert "uuid, syntax error"
+ (catch 'syntax-error
+ (lambda ()
+ (eval '(uuid "foobar") (current-module))
+ #f)
+ (lambda (key proc message location form . args)
+ (and (eq? proc 'uuid)
+ (string-contains message "invalid UUID")
+ (equal? form '(uuid "foobar" 'dce))))))
+
+(test-equal "uuid, ISO-9660, format preserved"
+ "1970-01-01-17-14-42-99"
+ (uuid->string (uuid "1970-01-01-17-14-42-99" 'iso9660)))
+
+(test-end)