aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-08-21 11:39:27 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-13 18:19:31 +0100
commit86bd64b613c799f23a8b378aa92365fad9ae72ed (patch)
tree85bce904d84fe865f0ca133829263b36840126f5
parent4f0ee1b4dff4fa224b7178134410b8821f137d13 (diff)
downloadguix-86bd64b613c799f23a8b378aa92365fad9ae72ed.tar
guix-86bd64b613c799f23a8b378aa92365fad9ae72ed.tar.gz
gnu: Add perl-yaml-libyaml.
* gnu/packages/perl.scm (perl-yaml-libyaml): New variable.
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d495fa25aa..09d6798177 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8836,6 +8836,30 @@ neither visible nor modifiable from Perl space).")
on the YAML 1.0 specification.")
(license (package-license perl))))
+(define-public perl-yaml-libyaml
+ (package
+ (name "perl-yaml-libyaml")
+ (version "0.65")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/T/TI/TINITA/YAML-LibYAML-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0izhvz8f29x1f50hhwfgm0iq1lz7apjjvg77lmky949jr07hnwfv"))))
+ (build-system perl-build-system)
+ (home-page
+ "http://search.cpan.org/dist/YAML-LibYAML")
+ (synopsis
+ "Perl YAML Serialization using XS and libyaml")
+ (description
+ "@code{YAML::XS} is a Perl XS binding to libyaml which offers Perl the
+best YAML support to date.")
+ (license perl-license)))
+
(define-public perl-yaml-tiny
(package
(name "perl-yaml-tiny")