aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-14 11:11:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-15 06:36:07 +0300
commit4072c10bee4ae236d64ed3f0d241cd2741914aa8 (patch)
treec68f63fa5b7a64ed4eb59ccfc5c70bb2520b5103
parented8cdab8708d0df31020feb0b7b63e55516ee129 (diff)
downloadguix-4072c10bee4ae236d64ed3f0d241cd2741914aa8.tar
guix-4072c10bee4ae236d64ed3f0d241cd2741914aa8.tar.gz
gnu: Add gcc-objc@6.
* gnu/packages/gcc.scm (gcc-objc@6): New variable.
-rw-r--r--gnu/packages/gcc.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 7c19a330ab..2a6877ffbf 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -603,6 +603,15 @@ as the 'native-search-paths' field."
(variable "LIBRARY_PATH")
(files '("lib" "lib64"))))))
+(define-public gcc-objc-6
+ (custom-gcc gcc-6 "gcc-objc" '("objc")
+ (list (search-path-specification
+ (variable "OBJC_INCLUDE_PATH")
+ (files '("include")))
+ (search-path-specification
+ (variable "LIBRARY_PATH")
+ (files '("lib" "lib64"))))))
+
(define-public gcc-objc gcc-objc-4.9)
(define-public gcc-objc++-4.8