aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-14 19:32:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-15 06:36:21 +0300
commit2206bd340b6d55b69779acc894d122eeea421339 (patch)
treedd668a6eff40b4d74d063f554f4304475164ae84
parent14728ab78f773f200d247b3b33a03645b06cf03a (diff)
downloadguix-2206bd340b6d55b69779acc894d122eeea421339.tar
guix-2206bd340b6d55b69779acc894d122eeea421339.tar.gz
gnu: Add gnucobol.
* gnu/packages/cobol.scm (gnucobol): New variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/cobol.scm59
2 files changed, 60 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4fefa3b10b..f2feca0524 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -88,6 +88,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/chez.scm \
%D%/packages/ci.scm \
%D%/packages/cmake.scm \
+ %D%/packages/cobol.scm \
%D%/packages/code.scm \
%D%/packages/commencement.scm \
%D%/packages/compression.scm \
diff --git a/gnu/packages/cobol.scm b/gnu/packages/cobol.scm
new file mode 100644
index 0000000000..f8f35928a7
--- /dev/null
+++ b/gnu/packages/cobol.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cobol)
+ #:use-module (gnu packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages multiprecision)
+ #:use-module (gnu packages ncurses))
+
+(define-public gnucobol
+ (package
+ (name "gnucobol")
+ (version "2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnu/gnucobol/gnucobol-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1814s1n95xax2dz938cf4fkcp0q94nkj1gjbdblbzpk9q92zq66w"))))
+ (arguments
+ '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out")
+ "/lib"))))
+ (inputs
+ `(("bdb" ,bdb)
+ ("gmp" ,gmp)
+ ("ncurses" ,ncurses)))
+ (build-system gnu-build-system)
+ (home-page "https://savannah.gnu.org/projects/gnucobol/")
+ (synopsis "A modern COBOL compiler")
+ (description "GnuCOBOL is a free, modern COBOL compiler. GnuCOBOL
+implements a substantial part of the COBOL 85, COBOL 2002 and COBOL 2014
+standards and X/Open COBOL, as well as many extensions included in other
+COBOL compilers (IBM COBOL, MicroFocus COBOL, ACUCOBOL-GT and others).
+GnuCOBOL translates COBOL into C and compiles the translated code using
+a native C compiler.")
+ (license gpl3+)))