aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-06-06 07:14:01 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-13 18:19:29 +0100
commit19d81cf7dc38233600b4664687e24027f4d1c6e4 (patch)
treeaa3241a00f0800b014727627b6792dc04a408b92
parent9d46919f9c0898f88e0635efeb837efcc9144fb9 (diff)
downloadguix-19d81cf7dc38233600b4664687e24027f4d1c6e4.tar
guix-19d81cf7dc38233600b4664687e24027f4d1c6e4.tar.gz
gnu: Add perl-test-cpan-meta-json.
* gnu/packages/perl.scm (perl-test-cpan-meta-json): New variable.
-rw-r--r--gnu/packages/perl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4463d22fd0..9cdddc1db2 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7056,6 +7056,34 @@ namespace::autoclean or namespace::clean and are therefore available to be
called as methods, which usually isn't want you want.")
(license (package-license perl))))
+(define-public perl-test-cpan-meta-json
+ (package
+ (name "perl-test-cpan-meta-json")
+ (version "0.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/B/BA/BARBIE/Test-CPAN-Meta-JSON-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1jg9ka50ixwq083wd4k12rhdjq87w0ihb34gd8jjn7gvvyd51b37"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+ (inputs
+ `(("perl-json" ,perl-json)))
+ (home-page
+ "http://search.cpan.org/dist/Test-CPAN-Meta-JSON")
+ (synopsis "Validate your CPAN META.json files")
+ (description
+ "This module was written to ensure that a META.json file meets the
+specification.")
+ (license artistic2.0)))
+
(define-public perl-test-deep
(package
(name "perl-test-deep")