aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-08-06 18:29:40 +0000
committerEfraim Flashner <efraim@flashner.co.il>2017-09-12 09:55:18 +0300
commit17df429ce66044e5f18a1d490cedf9a4a08da82f (patch)
treea4f91798b0f47dbc5370ba3efe34b9c2c777c70b
parent42a6eaacebe4d4611f4c9e0f53772434e5d939e6 (diff)
downloadguix-17df429ce66044e5f18a1d490cedf9a4a08da82f.tar
guix-17df429ce66044e5f18a1d490cedf9a4a08da82f.tar.gz
gnu: Add mate-terminal.
* gnu/packages/mate.scm (mate-terminal): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/mate.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 5962108655..18b7371d3c 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -168,6 +168,47 @@ desktop and the mate-about program.")
the MATE desktop environment.")
(license license:lgpl2.1+)))
+(define-public mate-terminal
+ (package
+ (name "mate-terminal")
+ (version "1.18.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1zihm609d2d9cw53ry385whshjl1dnkifpk41g1ddm9f58hv4da1"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("gobject-introspection" ,gobject-introspection)
+ ("libxml2" ,libxml2)
+ ("yelp-tools" ,yelp-tools)))
+ (inputs
+ `(("dconf" ,dconf)
+ ("gtk+" ,gtk+)
+ ("libice" ,libice)
+ ("libsm" ,libsm)
+ ("libx11" ,libx11)
+ ("mate-desktop" ,mate-desktop)
+ ("pango" ,pango)
+ ("vte" ,vte)))
+ (home-page "https://mate-desktop.org/")
+ (synopsis "MATE Terminal Emulator")
+ (description
+ "MATE Terminal is a terminal emulation application that you can
+use to access a shell. With it, you can run any application that
+is designed to run on VT102, VT220, and xterm terminals.
+MATE Terminal also has the ability to use multiple terminals
+in a single window (tabs) and supports management of different
+configurations (profiles).")
+ (license license:gpl3)))
+
(define-public mate-menus
(package
(name "mate-menus")