aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-22 12:59:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-22 16:24:24 +0200
commitbd3a184613e20155a8b3e417f00f4d59ff0935e6 (patch)
tree9cd1d2d97329fa83118a55f77f9ee979ed911103
parent6be54a8751ac36b9b2cd80f4914b11f89a087f6f (diff)
downloadguix-bd3a184613e20155a8b3e417f00f4d59ff0935e6.tar
guix-bd3a184613e20155a8b3e417f00f4d59ff0935e6.tar.gz
gnu: r-minimal: Do not compress serialized files.
* gnu/packages/statistics.scm (r-minimal)[arguments]: Replace build phase "patch-which" with "do-not-compress-serialized-files". [propagated-inputs]: Move "which" from here... [inputs]: ...to here. Fixes <https://bugs.gnu.org/28157>.
-rw-r--r--gnu/packages/statistics.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 7f6360fc7c..ad3032e2ec 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -126,11 +126,12 @@ be output in text, PostScript, PDF or HTML.")
"PKG_BUILT_STAMP=1970-01-01")
#:phases
(modify-phases %standard-phases
- ;; FIXME: see bug #28157.
- (add-before 'configure 'patch-which
+ (add-before 'configure 'do-not-compress-serialized-files
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/library/base/R/unix/system.unix.R"
- (("@WHICH@") "which"))
+ ;; This ensures that Guix can detect embedded store references;
+ ;; see bug #28157 for details.
+ (substitute* "src/library/base/makebasedb.R"
+ (("compress = TRUE") "compress = FALSE"))
#t))
(add-before 'configure 'patch-uname
(lambda* (#:key inputs #:allow-other-keys)
@@ -250,10 +251,8 @@ be output in text, PostScript, PDF or HTML.")
("libxt" ,libxt)
("pcre" ,pcre)
("readline" ,readline)
+ ("which" ,which)
("zlib" ,zlib)))
- ;; FIXME: By default Sys.which embeds a reference to "which", but this
- ;; reference is not detected by Guix (see bug #28157).
- (propagated-inputs `(("which" ,which)))
(native-search-paths
(list (search-path-specification
(variable "R_LIBS_SITE")