aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-08 14:54:39 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:21 +0100
commit9e8c6a37dbded0ee721067b4c4066df5f987203a (patch)
tree4a80c78fcbb8d7c2a703f54dde40fb1acfcf6785
parentb72ac1b54b5a4e94f2c57c5ee026133c0160ee60 (diff)
downloadguix-9e8c6a37dbded0ee721067b4c4066df5f987203a.tar
guix-9e8c6a37dbded0ee721067b4c4066df5f987203a.tar.gz
gnu: python-fonttools: Remove intervening directory in site-packges.
* gnu/packages/python.scm (python-fonttools): Add phase patch-setuppy.
-rw-r--r--gnu/packages/python.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index bf1a8251ba..b160ef5874 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5722,12 +5722,23 @@ term.js Javascript terminal emulator library.")
(base32
"08ay3x4ijarwhl60gqx2i9jzq6pxs20p4snc2d1q5jagh4rn39lb"))))
(build-system python-build-system)
- (arguments '(#:test-target "check"))
+ (arguments
+ '(#:test-target "check"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-setuppy
+ ;; Remove the undocumented "extra_path" argument, which adds an
+ ;; intervening directories between site-packages and the package
+ ;; directory.
+ (lambda _
+ (substitute* "setup.py"
+ (("^[ \t]*extra_path *= *'FontTools',") ""))
+ #t)))))
(home-page "http://github.com/behdad/fonttools")
(synopsis "Tools to manipulate font files")
(description
"FontTools/TTX is a library to manipulate font files from Python. It
-supports reading and writinfg of TrueType/OpenType fonts, reading and writing
+supports reading and writing of TrueType/OpenType fonts, reading and writing
of AFM files, reading (and partially writing) of PS Type 1 fonts. The package
also contains a tool called “TTX” which converts TrueType/OpenType fonts to and
from an XML-based format.")