aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2017-08-20 13:09:21 +0200
committerAndy Wingo <wingo@igalia.com>2017-08-20 13:11:06 +0200
commit96d36f385cb1de83f95dd0404dc2166d6f877389 (patch)
tree2ff740ef2330121719f2d5315785a71d2c3b280b
parenta9dbefdc9d8f52cf6a1965796d1d883a7c9689bd (diff)
downloadguix-96d36f385cb1de83f95dd0404dc2166d6f877389.tar
guix-96d36f385cb1de83f95dd0404dc2166d6f877389.tar.gz
gnu: Add gnome-default-applications.
* gnu/packages/gnome.scm (gnome-default-applications): New public variable. (gnome): Propagate gnome-default-applications so that nautilus is associated with folders, not baobab.
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6aa2e6adf2..1712ca0013 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5663,6 +5663,37 @@ configuration system for GNOME. It allows users to configure desktop
software that do not provide their own configuration interface.")
(license license:lgpl2.1+)))
+(define-public gnome-default-applications
+ (package
+ (name "gnome-default-applications")
+ (version "0")
+ (build-system trivial-build-system)
+ (source #f)
+ (propagated-inputs
+ `(("nautilus" ,nautilus)))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((out (assoc-ref %outputs "out"))
+ (apps (string-append out "/share/applications")))
+ (mkdir-p apps)
+ (call-with-output-file (string-append apps "/defaults.list")
+ (lambda (port)
+ (format port "[Default Applications]\n")
+ (format port "inode/directory=org.gnome.Nautilus.desktop\n")))
+ #t))))
+ (synopsis "Default MIME type associations for the GNOME desktop")
+ (description
+ "Given many installed packages which might handle a given MIME type, a
+user running the GNOME desktop probably has some preferences: for example,
+that folders be opened by default by the Nautilus file manager, not the Baobab
+disk usage analyzer. This package establishes that set of default MIME type
+associations for GNOME.")
+ (license license:gpl3+)
+ (home-page #f)))
+
(define-public gnome
(package
(name "gnome")
@@ -5692,6 +5723,7 @@ software that do not provide their own configuration interface.")
("gnome-calculator" ,gnome-calculator)
("gnome-control-center" ,gnome-control-center)
("gnome-disk-utility" ,gnome-disk-utility)
+ ("gnome-default-applications" ,gnome-default-applications)
("gnome-keyring" ,gnome-keyring)
("gnome-online-accounts" ,gnome-online-accounts)
("gnome-session" ,gnome-session)