aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2017-10-18 23:07:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-18 23:08:39 +0200
commitef5c40aa2dc59b923465a3719aa3c0965a8f833b (patch)
tree1bbcc05b4a4cae0f5d93e96a63fbb8e74039a6f7
parent07dfc89859a3539100a23c8acc0d643f4f7cb99d (diff)
downloadguix-ef5c40aa2dc59b923465a3719aa3c0965a8f833b.tar
guix-ef5c40aa2dc59b923465a3719aa3c0965a8f833b.tar.gz
gnu: Add atool.
* gnu/packages/compression.scm (atool): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/compression.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 72d61d25ed..f3142d1ddf 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
+;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,6 +51,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages check)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages file)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -1565,3 +1567,39 @@ zip archives. Files can be added from data buffers, files, or compressed data
copied directly from other zip archives. Changes made without closing the
archive can be reverted.")
(license license:bsd-3)))
+
+(define-public atool
+ (package
+ (name "atool")
+ (version "0.39.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://savannah.nongnu.org/download/atool/atool-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0fvhzip2v08jgnlfpyj6rapan39xlsl1ksgq4lp8gfsai2ah1xma"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'embed-absolute-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "atool"
+ (("(^\\$::cfg_path_file.*= )'file'" _ pre)
+ (string-append pre "'" (assoc-ref inputs "file")
+ "/bin/file'")))
+ #t)))))
+ (inputs
+ `(("perl" ,perl)
+ ("file" ,file)))
+ (home-page "http://www.nongnu.org/atool/")
+ (synopsis "Universal tool to manage file archives of various types")
+ (description "The main command is @command{aunpack} which extracts files
+from an archive. The other commands provided are @command{apack} (to create
+archives), @command{als} (to list files in archives), and @command{acat} (to
+extract files to standard out). As @command{atool} invokes external programs
+to handle the archives, not all commands may be supported for a certain type
+of archives.")
+ (license license:gpl2+)))