aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2017-10-15 16:03:23 -0400
committerLudovic Courtès <ludo@gnu.org>2017-10-19 12:17:43 +0200
commitc44dd0d67629ec787bdac1ae71f90b56a8e145e7 (patch)
tree5810996603cf3c95c0c51acd7f0b0413a6d749cb
parentb376ec57f982dad27feb13be7f1b9694e76625d1 (diff)
downloadguix-c44dd0d67629ec787bdac1ae71f90b56a8e145e7.tar
guix-c44dd0d67629ec787bdac1ae71f90b56a8e145e7.tar.gz
gnu: spice-gtk: Enable GObject introspection support.
Allows virt-manager to use the spice-gtk widget. * gnu/packages/spice.scm (spice-gtk)[inputs]: Add gobject-introspection. [arguments]<#:configure-flags>: Add --enable-introspection. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/spice.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 8e3c5e2b7f..7d49f90be9 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -162,6 +162,7 @@ which allows users to view a desktop computing environment.")
("spice-protocol" ,spice-protocol)))
(inputs
`(("glib-networking" ,glib-networking)
+ ("gobject-introspection" ,gobject-introspection)
("gtk+" ,gtk+)
("libepoxy" ,libepoxy)
("libjpeg" ,libjpeg)
@@ -182,7 +183,8 @@ which allows users to view a desktop computing environment.")
`(#:configure-flags
'("--enable-gstaudio"
"--enable-gstvideo"
- "--enable-pulse")
+ "--enable-pulse"
+ "--enable-introspection")
#:phases
(modify-phases %standard-phases
(add-after