aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-10-18 01:41:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-18 01:49:14 +0200
commitbfd073319cbde8dda68f0826efab310cc142a602 (patch)
tree3af016f4ddfb19ea1e20ae0dc3a78a076e726db1
parentdd12d4aad02fc83e00e7b09d676aa78bcb7dd476 (diff)
downloadguix-bfd073319cbde8dda68f0826efab310cc142a602.tar
guix-bfd073319cbde8dda68f0826efab310cc142a602.tar.gz
gnu: Add protobuf-c.
* gnu/packages/protobuf.scm (protobuf-c): New variable.
-rw-r--r--gnu/packages/protobuf.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 0a78dd7487..5d1cfa71e2 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -25,9 +25,10 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module ((guix licenses)
- #:select (bsd-3))
+ #:select (bsd-2 bsd-3))
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages python))
(define-public protobuf
@@ -52,6 +53,31 @@ yet extensible format. Google uses Protocol Buffers for almost all of its
internal RPC protocols and file formats.")
(license bsd-3)))
+(define-public protobuf-c
+ (package
+ (name "protobuf-c")
+ (version "1.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/protobuf-c/protobuf-c/"
+ "releases/download/v" version
+ "/protobuf-c-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18aj4xfv26zjmj44zbb01wk90jl7y4aj5xvbzz4gg748kdxavjax"))))
+ (build-system gnu-build-system)
+ (inputs `(("protobuf" ,protobuf)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/protobuf-c/protobuf-c")
+ (synopsis "Protocol Buffers implementation in C")
+ (description
+ "This is protobuf-c, a C implementation of the Google Protocol Buffers
+data serialization format. It includes @code{libprotobuf-c}, a pure C library
+that implements protobuf encoding and decoding, and @code{protoc-c}, a code
+generator that converts Protocol Buffer @code{.proto} files to C descriptor
+code.")
+ (license bsd-2)))
+
(define-public python-protobuf
(package
(name "python-protobuf")