aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-10-18 23:21:00 +0200
committerLudovic Courtès <ludo@gnu.org>2017-10-18 23:22:19 +0200
commitbaa6790b4c9d5aa0b987e4d5c86b06fa6d0d350c (patch)
treef07d03d39c0b0262ed87cbb2a32a49e01c38aa10
parent8cb537acbc7cbe0d5a21556f6123dd0c3ce6dcc6 (diff)
downloadguix-baa6790b4c9d5aa0b987e4d5c86b06fa6d0d350c.tar
guix-baa6790b4c9d5aa0b987e4d5c86b06fa6d0d350c.tar.gz
gnu: mailutils: Update to 3.3.
* gnu/packages/mail.scm (mailutils): Update to 3.3. [arguments]: Rename 'pre-build' phase to 'prepare-test-suite', and move after 'check'. Set 'HOME', and create ~/.mh_profile.
-rw-r--r--gnu/packages/mail.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a07cb1b004..574bb3f4b9 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2014 Sou Bunnbu <iyzsong@gmail.com>
@@ -117,19 +117,19 @@
(define-public mailutils
(package
(name "mailutils")
- (version "3.2")
+ (version "3.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/mailutils/mailutils-"
version ".tar.bz2"))
(sha256
(base32
- "0c06yj5hgqibi24ib9sx865kq6i1h18wn201g6iwcfbpi2a7psdm"))))
+ "1v110avpdz0bvz3yh3cfvvd0dnn7sa6hrpql2h8dgnri8fww6cag"))))
(build-system gnu-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before 'build 'pre-build
+ (add-before 'check 'prepare-test-suite
(lambda _
;; Use the right file name for `cat'.
(substitute* "testsuite/lib/mailutils.exp"
@@ -162,6 +162,17 @@
(("\\$\\(SHELL\\) \\$\\(TESTSUITE\\)" all)
(string-append "-" all)))
+ ;; 'frm' tests expect write access to $HOME.
+ (setenv "HOME" (getcwd))
+
+ ;; Avoid the message "I'm going to create the standard MH path
+ ;; for you", which would lead to one test failure (when diffing
+ ;; stdout of 'fmtcheck'.)
+ (call-with-output-file ".mh_profile"
+ (lambda (port)
+ (format port "Path: ~a/Mail-for-tests~%"
+ (getcwd))))
+
#t)))
;; TODO: Add `--with-sql'.
#:configure-flags '("--sysconfdir=/etc")