aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2017-10-19 01:13:15 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-19 01:13:40 +0200
commita1777c77f0d815d9ab7c03639543d4d18d92093d (patch)
tree7c8a411a2d43a36bb6a05ac8de8dcf01dca3f3ee
parent7f926760ed3617bccf95b5a5c6a342955b9c470d (diff)
downloadguix-a1777c77f0d815d9ab7c03639543d4d18d92093d.tar
guix-a1777c77f0d815d9ab7c03639543d4d18d92093d.tar.gz
gnu: Add perl-libtime-period.
* gnu/packages/perl.scm (perl-libtime-period): New variable.
-rw-r--r--gnu/packages/perl.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 2d19e19c7c..47c35dcf56 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9227,3 +9227,30 @@ in Perl source files.")
(license (non-copyleft "http://metadata.ftp-master.debian.org/\
changelogs/main/libt/libtime-parsedate-perl/\
libtime-parsedate-perl_2015.103-2_copyright"))))
+
+(define-public perl-libtime-period
+ (package
+ (name "perl-libtime-period")
+ (version "1.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://http.debian.net/debian/pool/main/libt/"
+ "libtime-period-perl/libtime-period-perl_"
+ version ".orig.tar.gz"))
+ (sha256
+ (base32 "0c0yd999h0ikj88c9j95wa087m87i0qh7vja3715y2kd7vixkci2"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ ;; Unless some other homepage is out there...
+ (home-page "https://packages.debian.org/stretch/libtime-period-perl")
+ (synopsis "Perl library for testing if a time() is in a specific period")
+ (description "This Perl library provides a function which tells whether a
+specific time falls within a specified time period. Its syntax for specifying
+time periods allows you to test for conditions like \"Monday to Friday, 9am
+till 5pm\" and \"on the second Tuesday of the month\" and \"between 4pm and
+4:15pm\" and \"in the first half of each minute\" and \"in January of
+1998\".")
+ (license perl-license)))