aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-10-12 10:22:27 +0200
committerLudovic Courtès <ludo@gnu.org>2017-10-14 17:07:36 +0200
commit7aafb3b324055fab42fa28fe527f86966e85de8e (patch)
tree4c6a1d1a76e0eb42f04a6e67b1ef2ae64d786d86
parent8380a1817603e0f2b30fca2bc26923f6c93ae1c7 (diff)
downloadguix-7aafb3b324055fab42fa28fe527f86966e85de8e.tar
guix-7aafb3b324055fab42fa28fe527f86966e85de8e.tar.gz
gnu: games: Add openrct2.
* gnu/packages/games.scm (openrct2): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/games.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f8c971f32d..04b7b78d36 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -133,6 +133,7 @@
#:use-module (gnu packages gnuzilla)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages networking)
+ #:use-module (gnu packages web)
#:use-module (guix build-system gnu)
#:use-module (guix build-system haskell)
#:use-module (guix build-system python)
@@ -2628,6 +2629,56 @@ Transport Tycoon Deluxe.")
("opensfx" ,openttd-opensfx)
,@(package-native-inputs openttd-engine)))))
+(define-public openrct2
+ (package
+ (name "openrct2")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/OpenRCT2/OpenRCT2/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1bahkzlf9k92cc4zs4nk4wy59323kiw8d3wm0vjps3kp7iznqyjx"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;; no tests available
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'fix-cmake-install-file
+ (lambda _
+ ;; The build system tries to download a file and compare hashes.
+ ;; Since we have no network, remove this so the install doesn't fail.
+ (substitute* "cmake_install.cmake"
+ (("EXPECTED_HASH SHA1=b587d83de508d0b104d14c599b76f8565900fce0")
+ "")))))))
+ (inputs `(("curl", curl)
+ ("fontconfig", fontconfig)
+ ("freetype", freetype)
+ ("jansson", jansson)
+ ("libpng", libpng)
+ ("libzip", libzip)
+ ("mesa", mesa)
+ ("openssl", openssl)
+ ("sdl2", sdl2)
+ ("speexdsp", speexdsp)
+ ("zlib", zlib)))
+ (native-inputs
+ `(("pkg-config", pkg-config)))
+ (home-page "https://github.com/OpenRCT2/OpenRCT2")
+ (synopsis "Free software re-implementation of RollerCoaster Tycoon 2")
+ (description "OpenRCT2 is a free software re-implementation of
+RollerCoaster Tycoon 2 (RCT2). The gameplay revolves around building and
+maintaining an amusement park containing attractions, shops and facilities.
+
+Note that this package does @emph{not} provide the game assets (sounds,
+images, etc.)")
+ ;; See <https://github.com/OpenRCT2/OpenRCT2/wiki/Required-RCT2-files>
+ ;; regarding assets.
+ (license license:gpl3+)))
+
(define-public pinball
(package
(name "pinball")