aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-10-17 09:59:06 +0200
committerRoel Janssen <roel@gnu.org>2017-10-17 09:59:06 +0200
commit4640a11bee7935e2063afda600afb747dc0f4e0b (patch)
treefd9a21ecd0e17b84f3040c1546c6f4373cda0393
parent09748a352729762dacb8e6171752aaa6d03df85d (diff)
downloadguix-4640a11bee7935e2063afda600afb747dc0f4e0b.tar
guix-4640a11bee7935e2063afda600afb747dc0f4e0b.tar.gz
gnu: Add python2-neo4j-driver.
* gnu/packages/python.scm (python2-neo4j-driver): New variable.
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cab910be7d..68951d6bb3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7549,6 +7549,27 @@ and MAC network addresses.")
(define-public python2-netaddr
(package-with-python2 python-netaddr))
+(define-public python2-neo4j-driver
+ (package
+ (name "python2-neo4j-driver")
+ ;; NOTE: When upgrading to 1.5.0, please add a python3 variant.
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "neo4j-driver" version))
+ (sha256
+ (base32
+ "011r1vh182p8mm83d8dz9rfnc3l7rf7fd00cyrbyfzi71jmc4g98"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (home-page "https://neo4j.com/developer/python/")
+ (synopsis "Neo4j driver code written in Python")
+ (description "This package provides the Neo4j Python driver that connects
+to the database using Neo4j's binary protocol. It aims to be minimal, while
+being idiomatic to Python.")
+ (license license:asl2.0)))
+
(define-public python-wrapt
(package
(name "python-wrapt")