aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:10:47 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:51 -0400
commitf20d1300b3178af2f58a1217a2bd448e0d3bd031 (patch)
treee7fd20658883c9f6ba8ea7368e4a5f16aff1774a
parent303dfd5c568d024eabb5cd6c877052ba82c2a00f (diff)
downloadguix-f20d1300b3178af2f58a1217a2bd448e0d3bd031.tar
guix-f20d1300b3178af2f58a1217a2bd448e0d3bd031.tar.gz
gnu: Add go-golang-org-x-net-internal-iana.
* gnu/packages/syncthing.scm (go-golang-org-x-net-internal-iana): New variable.
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index c535f57a90..692ad7ed05 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1062,6 +1062,32 @@ request-scoped values across API boundaries and between processes.")
(home-page "https://go.googlesource.com/net/")
(license bsd-3))))
+(define-public go-golang-org-x-net-internal-iana
+ (let ((commit "ffcf1bedda3b04ebb15a168a59800a73d6dc0f4d")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-net-internal-iana")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/net")
+ (commit commit)))
+ (file-name (string-append "go.googlesource.com-net-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "1ifqw09pj9q23mza1d0im99yy3jp72dvq9dcx2bs1n1m11cjdjzp"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/net/internal/iana"
+ #:unpack-path "golang.org/x/net"))
+ (synopsis "Go support for assigned numbers (IANA)")
+ (description "This packages provides @code{iana}, which provides protocol
+number resources managed by the Internet Assigned Numbers Authority (IANA).")
+ (home-page "https://go.googlesource.com/net/")
+ (license bsd-3))))
+
(define-public go-golang-org-x-sys-unix
(let ((commit "f3918c30c5c2cb527c0b071a27c35120a6c0719a")
(revision "0"))