aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:19:07 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:53 -0400
commitcb42a2a89d0f60ae6b9be18b0306a5f0fa3b1889 (patch)
treecb2653c190b5e174771c1ca2c08fd7abcba7bb41
parent3ce463908af55d8711f7f802b3f7414de5d20185 (diff)
downloadguix-cb42a2a89d0f60ae6b9be18b0306a5f0fa3b1889.tar
guix-cb42a2a89d0f60ae6b9be18b0306a5f0fa3b1889.tar.gz
gnu: Add go-golang-org-x-time-rate.
* gnu/packages/syncthing.scm (go-golang-org-x-time-rate): New variable.
-rw-r--r--gnu/packages/syncthing.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 899e4e631d..86f1843f08 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1371,6 +1371,33 @@ error handling primitives in Go.")
(home-page "https://github.com/pkg/errors")
(license bsd-2))))
+(define-public go-golang-org-x-time-rate
+ (let ((commit "f51c12702a4d776e4c1fa9b0fabab841babae631")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-time-rate")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/time")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07wc6g2fvafkr6djsscm0jpbpl4135khhb6kpyx1953hi5d1jvyy"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/time/rate"
+ #:unpack-path "golang.org/x/time"))
+ (propagated-inputs
+ `(("go-golang-org-x-net-context" ,go-golang-org-x-net-context)))
+ (synopsis "Rate limiting in Go")
+ (description "This package provides @{rate}, which implements rate
+limiting in Go.")
+ (home-page "https://godoc.org/golang.org/x/time/rate")
+ (license bsd-3))))
+
(define-public go-github-com-petermattis-goid
(let ((commit "3db12ebb2a599ba4a96bea1c17b61c2f78a40e02")
(revision "0"))