aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:55:35 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:46 -0400
commitb32eab0b4c81fa998562c81addb367b5581d9bae (patch)
treee2fb9d6d2f64885d53c27ca2fe0dcf9f2be3b39d
parentede4f50c6b1d29401fe14908dfa96f6355feaf7e (diff)
downloadguix-b32eab0b4c81fa998562c81addb367b5581d9bae.tar
guix-b32eab0b4c81fa998562c81addb367b5581d9bae.tar.gz
gnu: Add go-github-com-golang-snappy.
* gnu/packages/syncthing.scm (go-github-com-golang-snappy): New variable.
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 96bebadc6f..f4fece302b 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -283,3 +283,27 @@ mechanism with caching and de-duplication that works across a set of peer
processes.")
(home-page "https://github.com/golang/groupcache")
(license asl2.0))))
+
+(define-public go-github-com-golang-snappy
+ (let ((commit "553a641470496b2327abcac10b36396bd98e45c9")
+ (revision "0"))
+ (package
+ (name "go-github-com-golang-snappy")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golang/snappy")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0kssxnih1l722hx9219c7javganjqkqhvl3i0hp0hif6xm6chvqk"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/golang/snappy"))
+ (synopsis "Snappy compression format in the Go programming language")
+ (description "This package provides a Go implementation of the Snappy
+compression format.")
+ (home-page "https://github.com/golang/snappy")
+ (license bsd-3))))