aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:45:46 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:44 -0400
commitadd56f346991696b74cd6318dc7dfaa1e7fffba6 (patch)
tree025f6d195f38c86741216baf6d6f12d31cac84c7
parent67b468182acb7b59fac454349ad6225d043de079 (diff)
downloadguix-add56f346991696b74cd6318dc7dfaa1e7fffba6.tar
guix-add56f346991696b74cd6318dc7dfaa1e7fffba6.tar.gz
gnu: Add go-github-com-calmh-du.
* gnu/packages/syncthing.scm (go-github-com-calmh-du): New variable.
-rw-r--r--gnu/packages/syncthing.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 225af85cfc..ec995fff39 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -70,3 +70,25 @@ firewall.")
the LZ4 compression algorithm.")
(home-page "https://github.com/bkaradzic/go-lz4")
(license bsd-2))))
+
+(define-public go-github-com-calmh-du
+ (package
+ (name "go-github-com-calmh-du")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/calmh/du")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qb3a6y3p9nkyn3s66k6zcm16y8n8578qh23ddj14cxf2scrr2n2"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/calmh/du"))
+ (synopsis "Get total and available disk space of a given volume")
+ (description "This is a Go implementation of `du`. It provides disk usage
+information, such as how much storage space is available, free, and used.")
+ (home-page "https://github.com/calmh/du")
+ (license public-domain)))