aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 01:08:22 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:47 -0400
commita57778f58526ce6f147b17e6c4196b7d247e1f43 (patch)
treec927d7eba5fae6ff25914609c58880565b9b7ac0
parentbde48edc0fc8f42209fd0173afa7572b6bf7df56 (diff)
downloadguix-a57778f58526ce6f147b17e6c4196b7d247e1f43.tar
guix-a57778f58526ce6f147b17e6c4196b7d247e1f43.tar.gz
gnu: Add go-github-com-oschwald-maxminddb-golang.
* gnu/packages/syncthing.scm (go-github-com-oschwald-maxminddb-golang): New variable.
-rw-r--r--gnu/packages/syncthing.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index f674152b45..0cc08db63d 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -409,6 +409,34 @@ architectures.")
(home-page "https://github.com/minio/sha256-simd")
(license asl2.0))))
+(define-public go-github-com-oschwald-maxminddb-golang
+ (let ((commit "697da8075d2061aa8ed639346443f5d3e8c80b30")
+ (revision "0"))
+ (package
+ (name "go-github-com-oschwald-maxminddb-golang")
+ (version (git-version "0.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oschwald/maxminddb-golang")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00kkxzlvra0kcbkl56wp0dp1yw3cmfjqqlwbqy7bq5r34s7iavq0"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ `(("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
+ (arguments
+ `(#:import-path "github.com/oschwald/maxminddb-golang"
+ #:tests? #f)) ; Requires some unpackaged software and test data
+ (synopsis "MaxMind DB Reader for Go")
+ (description "This is a Go reader for the MaxMind DB format. Although
+this can be used to read GeoLite2 and GeoIP2 databases, @code{geoip2} provides a
+higher-level API for doing so.")
+ (home-page "https://github.com/oschwald/maxminddb-golang")
+ (license isc))))
+
(define-public go-golang-org-x-sys-unix
(let ((commit "f3918c30c5c2cb527c0b071a27c35120a6c0719a")
(revision "0"))