aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:21:32 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:54 -0400
commita3d98dd8d93a1d7bdb43437b52bfca736e8e3f5c (patch)
treead52c7ad9a6fd31d78f7979cda627c2fb9890297
parent89d91ee2a04c286c442aa8636fafe7b7a85107df (diff)
downloadguix-a3d98dd8d93a1d7bdb43437b52bfca736e8e3f5c.tar
guix-a3d98dd8d93a1d7bdb43437b52bfca736e8e3f5c.tar.gz
gnu: Add go-github-com-templexxx-cpufeat.
* gnu/packages/syncthing.scm (go-github-com-templexxx-cpufeat): New variable.
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index b7acdb9fbe..b728c8f28b 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1470,3 +1470,27 @@ interfaces in Go.")
using sh's word-splitting rules.")
(home-page "https://github.com/kballard/go-shellquote")
(license expat))))
+
+(define-public go-github-com-templexxx-cpufeat
+ (let ((commit "3794dfbfb04749f896b521032f69383f24c3687e")
+ (revision "0"))
+ (package
+ (name "go-github-com-templexxx-cpufeat")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/templexxx/cpufeat.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0b9f5p6nsiv907rz5d66qzgxnsz4k68r2f45vxi2hwdbnkjfxz8j"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/templexxx/cpufeat"))
+ (synopsis "CPU feature identification for Go")
+ (description "This package provides @code{cpu}, which implements
+processor feature detection used by the Go standard libary.")
+ (home-page "https://github.com/templexxx/cpufeat")
+ (license bsd-3))))