aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:48:55 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:45 -0400
commita3a5b01240174b0d5e12b41dd1187c106d88de6d (patch)
tree6d5b5b05a158495adbd58632f59512bfc6149cd7
parentab3e15899c6d37e7310e7403fdc72b2b4ae694fa (diff)
downloadguix-a3a5b01240174b0d5e12b41dd1187c106d88de6d.tar
guix-a3a5b01240174b0d5e12b41dd1187c106d88de6d.tar.gz
gnu: Add go-github-com-edsrzf-mmap-go.
* gnu/packages/syncthing.scm (go-github-com-edsrzf-mmap-go): New variable.
-rw-r--r--gnu/packages/syncthing.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 4d1b2a86fe..a98502ce5a 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -141,3 +141,26 @@ reflection.")
structs in the Go programming language.")
(home-page "https://github.com/d4l3k/messagediff")
(license expat))))
+
+(define-public go-github-com-edsrzf-mmap-go
+ (let ((commit "0bce6a6887123b67a60366d2c9fe2dfb74289d2e")
+ (revision "0"))
+ (package
+ (name "go-github-com-edsrzf-mmap-go")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/edsrzf/mmap-go")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1am4m2k451bksnbiqj6lxknk4lsgmrhv0q3ajqac818vj0cpfgs9"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/edsrzf/mmap-go"))
+ (synopsis "Go implementation of mmap")
+ (description "This packages provides a Go implementation of mmap.")
+ (home-page "https://github.com/edsrzf/mmap-go")
+ (license bsd-3))))