aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:06:54 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:50 -0400
commit932fb477552999183ccdb38c44b367d088f63e88 (patch)
tree12aeab1caf7c6089044d4a1ed7f1c496c84fd828
parent95b493f2a8b423a178be919bb5a517b4b414a015 (diff)
downloadguix-932fb477552999183ccdb38c44b367d088f63e88.tar
guix-932fb477552999183ccdb38c44b367d088f63e88.tar.gz
gnu: Add go-golang-org-x-crypto-twofish.
* gnu/packages/syncthing.scm (go-golang-org-x-crypto-twofish): New variable.
-rw-r--r--gnu/packages/syncthing.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index a5f2e6c565..865cf2d7e6 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -910,6 +910,43 @@ symmetric-key block cipher.")
(home-page "https://go.googlesource.com/crypto/")
(license bsd-3))))
+(define-public go-golang-org-x-crypto-twofish
+ (let ((commit "c78caca803c95773f48a844d3dcab04b9bc4d6dd")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-crypto-twofish")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/crypto")
+ (commit commit)))
+ (file-name (string-append "go.googlesource.com-crypto-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "0vxlfxr9y681yn2cfh6dbqmq35vvq4f45ay0mm31ffkny9cms0y4"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/crypto/twofish"
+ #:unpack-path "golang.org/x/crypto"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map (lambda (file)
+ (make-file-writable file))
+ (find-files
+ (string-append (assoc-ref outputs "out")
+ "/src/golang.org/x/crypto/ed25519/testdata")
+ ".*\\.gz$"))
+ #t)))))
+ (synopsis "Twofish in Go")
+ (description "This packages provides a Go implementation of the Twofish
+symmetric-key block cipher.")
+ (home-page "https://go.googlesource.com/crypto/")
+ (license bsd-3))))
+
(define-public go-golang-org-x-sys-unix
(let ((commit "f3918c30c5c2cb527c0b071a27c35120a6c0719a")
(revision "0"))