aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:20:40 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:53 -0400
commit89d91ee2a04c286c442aa8636fafe7b7a85107df (patch)
treea1a68f0ef1a97911038ebd45863606be266e3c3c
parent71415e23f9eaabf6a4537f12e9c19ecfe85481e9 (diff)
downloadguix-89d91ee2a04c286c442aa8636fafe7b7a85107df.tar
guix-89d91ee2a04c286c442aa8636fafe7b7a85107df.tar.gz
gnu: Add go-github-com-kballard-go-shellquote.
* gnu/packages/syncthing.scm (go-github-com-kballard-go-shellquote): New variable.
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 90cec8e116..b7acdb9fbe 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1446,3 +1446,27 @@ the current goroutine's ID.")
interfaces in Go.")
(home-page "https://github.com/AudriusButkevicius/cli")
(license expat))))
+
+(define-public go-github-com-kballard-go-shellquote
+ (let ((commit "cd60e84ee657ff3dc51de0b4f55dd299a3e136f2")
+ (revision "0"))
+ (package
+ (name "go-github-com-kballard-go-shellquote")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kballard/go-shellquote.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xjpin4jq1zl84dcn96xhjmn9bsfyszf6g9aqyj2dc0xfi6c88y0"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/kballard/go-shellquote"))
+ (synopsis "Shell-style string joins and splits")
+ (description "Shellquote provides utilities for joining/splitting strings
+using sh's word-splitting rules.")
+ (home-page "https://github.com/kballard/go-shellquote")
+ (license expat))))