aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:57:47 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:46 -0400
commit7577a1d520b8539e6c9e643de4d7dc51ef2c092f (patch)
tree8e925b83f9c9e14552a96bd70f6884891172def2
parent7b92093d1848745668cafe56cdcdfb209c348039 (diff)
downloadguix-7577a1d520b8539e6c9e643de4d7dc51ef2c092f.tar
guix-7577a1d520b8539e6c9e643de4d7dc51ef2c092f.tar.gz
gnu: Add go-github-com-kardianos-osext.
* gnu/packages/syncthing.scm (go-github-com-kardianos-osext): New variable.
-rw-r--r--gnu/packages/syncthing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index c3f354e590..878a51c5f9 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -331,3 +331,28 @@ compression format.")
address of the default LAN gateway.")
(home-page "https://github.com/jackpal/gateway")
(license bsd-3))))
+
+(define-public go-github-com-kardianos-osext
+ (let ((commit "9d302b58e975387d0b4d9be876622c86cefe64be")
+ (revision "0"))
+ (package
+ (name "go-github-com-kardianos-osext")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kardianos/osext")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0r6f727s16g4f66k8c2z1xh8ga1p53hg9g2v95pmhd1i60fhy47a"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/kardianos/osext"))
+ (synopsis "Find the running executable")
+ (description "Osext provides a method for finding the current executable
+file that is running. This can be used for upgrading the current executable or
+finding resources located relative to the executable file.")
+ (home-page "https://github.com/kardianos/osext")
+ (license bsd-3))))