aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 01:11:37 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:48 -0400
commit73a2f8418d85254a2648e760cf4e48ebf7ac749e (patch)
treeccd8b0b96962c2cbdc473ba7c5e697d028134026
parent1a4795f9d0bb922a896820c5679686e4be41e21c (diff)
downloadguix-73a2f8418d85254a2648e760cf4e48ebf7ac749e.tar
guix-73a2f8418d85254a2648e760cf4e48ebf7ac749e.tar.gz
gnu: Add go-github-com-petermattis-goid.
* gnu/packages/syncthing.scm (go-github-com-petermattis-goid): New variable.
-rw-r--r--gnu/packages/syncthing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5b597f1c41..1fb25d7b84 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -539,3 +539,28 @@ Metrics library.")
for low-level interaction with the operating system.")
(home-page "https://go.googlesource.com/sys")
(license bsd-3))))
+
+(define-public go-github-com-petermattis-goid
+ (let ((commit "3db12ebb2a599ba4a96bea1c17b61c2f78a40e02")
+ (revision "0"))
+ (package
+ (name "go-github-com-petermattis-goid")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/petermattis/goid.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+
+ (base32
+ "0z18a3mr72c52g7g94n08gxw0ksnaafbfwdl5p5jav2sffirb0kd"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/petermattis/goid"))
+ (synopsis "Identify the running goroutine")
+ (description "This package offers a method of programatically retrieving
+the current goroutine's ID.")
+ (home-page "https://github.com/petermattis/goid")
+ (license asl2.0))))