aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:00:14 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:49 -0400
commit6934827a3e1fb8455a7a7c07375cc60da7c9b8bd (patch)
tree3f4c3505cdf6e009908333d72674a9850e31878f
parent292a6b0d16e19a5cb960053d6da631754b1b5795 (diff)
downloadguix-6934827a3e1fb8455a7a7c07375cc60da7c9b8bd.tar
guix-6934827a3e1fb8455a7a7c07375cc60da7c9b8bd.tar.gz
gnu: Add go-github-com-vitrun-qart-gf256.
* gnu/packages/syncthing.scm (go-github-com-vitrun-qart-gf256): New variable.
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index d1471075d2..8ff3621814 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -630,6 +630,32 @@ low-level QR coding details.")
(home-page "https://github.com/vitrun/qart/")
(license bsd-3))))
+(define-public go-github-com-vitrun-qart-gf256
+ (let ((commit "bf64b92db6b05651d6c25a3dabf2d543b360c0aa")
+ (revision "0"))
+ (package
+ (name "go-github-com-vitrun-qart-gf256")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vitrun/qart")
+ (commit commit)))
+ (file-name (string-append "go-github-com-vitrun-qart-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "1xk7qki703xmay9ghi3kq2bjf1iw9dz8wik55739d6i7sn77vvkc"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/vitrun/qart/gf256"
+ #:unpack-path "github.com/vitrun/qart"))
+ (synopsis "Qart library for Galois Field GF(256) math")
+ (description "This package, a component of @code{qart}, provides @code{gf256},
+implements arithmetic over the Galois Field GF(256).")
+ (home-page "https://github.com/vitrun/qart")
+ (license bsd-3))))
+
(define-public go-golang-org-x-sys-unix
(let ((commit "f3918c30c5c2cb527c0b071a27c35120a6c0719a")
(revision "0"))