aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:04:47 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:49 -0400
commit63950f9b39c1c20c2ca88f53518e898739e3c160 (patch)
treec7a853d2d48fcebfb00e7e939f5aa80656afe695
parentb65620b6d2383ef8a283a846a38c86db29aee3c4 (diff)
downloadguix-63950f9b39c1c20c2ca88f53518e898739e3c160.tar
guix-63950f9b39c1c20c2ca88f53518e898739e3c160.tar.gz
gnu: Add go-golang-org-x-crypto-tea.
* gnu/packages/syncthing.scm (go-golang-org-x-crypto-tea): New variable.
-rw-r--r--gnu/packages/syncthing.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 95d1f36cec..5cf9b95592 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -799,6 +799,43 @@ derivation function.")
(home-page "https://go.googlesource.com/crypto/")
(license bsd-3))))
+(define-public go-golang-org-x-crypto-tea
+ (let ((commit "c78caca803c95773f48a844d3dcab04b9bc4d6dd")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-crypto-tea")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/crypto")
+ (commit commit)))
+ (file-name (string-append "go.googlesource.com-crypto-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "0vxlfxr9y681yn2cfh6dbqmq35vvq4f45ay0mm31ffkny9cms0y4"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/crypto/tea"
+ #:unpack-path "golang.org/x/crypto"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map (lambda (file)
+ (make-file-writable file))
+ (find-files
+ (string-append (assoc-ref outputs "out")
+ "/src/golang.org/x/crypto/ed25519/testdata")
+ ".*\\.gz$"))
+ #t)))))
+ (synopsis "Tiny Encryption Algorithm (TEA) in Go")
+ (description "This packages a Go implementation of the Tiny Encryption
+Algorithm (TEA) block cipher.")
+ (home-page "https://go.googlesource.com/crypto/")
+ (license bsd-3))))
+
(define-public go-golang-org-x-sys-unix
(let ((commit "f3918c30c5c2cb527c0b071a27c35120a6c0719a")
(revision "0"))