aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:28:30 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:55 -0400
commit4c3cc9496c1f98bc5160ea7a7548664c15aa64dc (patch)
treee83b385defbace8dbf0748afa60b9827ad9edc33
parent3c466da1d54b5225fe74eea8162aa9ab97fd7933 (diff)
downloadguix-4c3cc9496c1f98bc5160ea7a7548664c15aa64dc.tar
guix-4c3cc9496c1f98bc5160ea7a7548664c15aa64dc.tar.gz
gnu: Add go-golang-org-x-net-union.
* gnu/packages/syncthing.scm (go-golang-org-x-net-union): New variable.
-rw-r--r--gnu/packages/syncthing.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 653cd3a00a..2ac39d1f17 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1073,6 +1073,35 @@ Tiny Encryption Algorithm (XTEA) block cipher.")
(home-page "https://go.googlesource.com/crypto/")
(license bsd-3))))
+(define* (go-golang-org-x-net-union #:optional
+ (packages (list go-golang-org-x-net-ipv4
+ go-golang-org-x-net-bpf
+ go-golang-org-x-net-context
+ go-golang-org-x-net-ipv6
+ go-golang-org-x-net-proxy
+ go-golang-org-x-net-internal-iana)))
+ (package
+ (name "go-golang-org-x-net")
+ (version (package-version go-golang-org-x-net-ipv4))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments
+ '(#:modules ((guix build union))
+ #:builder (begin
+ (use-modules (ice-9 match)
+ (guix build union))
+ (match %build-inputs
+ (((names . directories) ...)
+ (union-build (assoc-ref %outputs "out")
+ directories))))))
+ (inputs (map (lambda (package)
+ (list (package-name package) package))
+ packages))
+ (synopsis "Union of the Go net libraries")
+ (description "A union of the Golang net libraries.")
+ (home-page (package-home-page go-golang-org-x-net-ipv4))
+ (license (package-license go-golang-org-x-net-ipv4))))
+
(define-public go-golang-org-x-net-ipv4
(let ((commit "ffcf1bedda3b04ebb15a168a59800a73d6dc0f4d")
(revision "0"))