aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:58:57 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:47 -0400
commit4a9c4dbe3beea4cb9809cdf2ce6105143f705ac9 (patch)
treeb20a533176fce2fd9b4c91e67e832958cbee457d
parent340e1a9a2426f6947f119b87715e2092a805c9f3 (diff)
downloadguix-4a9c4dbe3beea4cb9809cdf2ce6105143f705ac9.tar
guix-4a9c4dbe3beea4cb9809cdf2ce6105143f705ac9.tar.gz
gnu: Add go-github-com-minio-sha256-simd.
* gnu/packages/syncthing.scm (go-github-com-minio-sha256-simd): New variable.
-rw-r--r--gnu/packages/syncthing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 0325a0f595..1a14fa90a7 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -383,3 +383,28 @@ finding resources located relative to the executable file.")
database/sql package.")
(home-page "https://github.com/lib/pq")
(license expat))))
+
+(define-public go-github-com-minio-sha256-simd
+ (let ((commit "6124d070eb4e7001c244b6ccc282620a5dce44a0")
+ (revision "0"))
+ (package
+ (name "go-github-com-minio-sha256-simd")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minio/sha256-simd")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1azrdp7x7vl9ngkxs890blspz0345xhadvssdlb0435hdqa0gkll"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/minio/sha256-simd"))
+ (synopsis "Hardware-accelerated SHA256 in Go using SIMD")
+ (description "This packages provides a pure Go implementation of SHA256
+using SIMD (Single instruction, multiple data) instructions for Intel and ARM
+architectures.")
+ (home-page "https://github.com/minio/sha256-simd")
+ (license asl2.0))))