aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:09:29 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:51 -0400
commit3544d5259c28f8b1d50ba8d89a24b31e6d610527 (patch)
treeea84214278ed9188976ef9c1defb3a12eceed216
parentb5ad117bb21de54d9e22758da3602ac58d8c00ba (diff)
downloadguix-3544d5259c28f8b1d50ba8d89a24b31e6d610527.tar
guix-3544d5259c28f8b1d50ba8d89a24b31e6d610527.tar.gz
gnu: Add go-golang-org-x-net-bpf.
* gnu/packages/syncthing.scm (go-golang-org-x-net-bpf): New variable.
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 82b59a61e7..829842bfb2 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1009,6 +1009,32 @@ socket options for the Internet Protocol version 4.")
(home-page "https://go.googlesource.com/net")
(license bsd-3))))
+(define-public go-golang-org-x-net-bpf
+ (let ((commit "ffcf1bedda3b04ebb15a168a59800a73d6dc0f4d")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-net-bpf")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/net")
+ (commit commit)))
+ (file-name (string-append "go.googlesource.com-net-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "1ifqw09pj9q23mza1d0im99yy3jp72dvq9dcx2bs1n1m11cjdjzp"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/net/bpf"
+ #:unpack-path "golang.org/x/net"))
+ (synopsis "Berkeley Packet Filters (BPF) in Go")
+ (description "This packages provides a Go implementation of the Berkeley
+Packet Filter (BPF) virtual machine.")
+ (home-page "https://go.googlesource.com/net/")
+ (license bsd-3))))
+
(define-public go-golang-org-x-sys-unix
(let ((commit "f3918c30c5c2cb527c0b071a27c35120a6c0719a")
(revision "0"))