aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:10:06 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:51 -0400
commit303dfd5c568d024eabb5cd6c877052ba82c2a00f (patch)
treebf63cd0adb7d54ebc14d50e4746ef9c9948802e6
parent3544d5259c28f8b1d50ba8d89a24b31e6d610527 (diff)
downloadguix-303dfd5c568d024eabb5cd6c877052ba82c2a00f.tar
guix-303dfd5c568d024eabb5cd6c877052ba82c2a00f.tar.gz
gnu: Add go-golang-org-x-net-context.
* gnu/packages/syncthing.scm (go-golang-org-x-net-context): New variable.
-rw-r--r--gnu/packages/syncthing.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 829842bfb2..c535f57a90 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1035,6 +1035,33 @@ Packet Filter (BPF) virtual machine.")
(home-page "https://go.googlesource.com/net/")
(license bsd-3))))
+(define-public go-golang-org-x-net-context
+ (let ((commit "ffcf1bedda3b04ebb15a168a59800a73d6dc0f4d")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-net-context")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/net")
+ (commit commit)))
+ (file-name (string-append "go.googlesource.com-net-"
+ version "-checkout"))
+ (sha256
+ (base32
+ "1ifqw09pj9q23mza1d0im99yy3jp72dvq9dcx2bs1n1m11cjdjzp"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/net/context"
+ #:unpack-path "golang.org/x/net"))
+ (synopsis "Golang Context type")
+ (description "This packages provides @code{context}, which defines the
+Context type, which carries deadlines, cancelation signals, and other
+request-scoped values across API boundaries and between processes.")
+ (home-page "https://go.googlesource.com/net/")
+ (license bsd-3))))
+
(define-public go-golang-org-x-sys-unix
(let ((commit "f3918c30c5c2cb527c0b071a27c35120a6c0719a")
(revision "0"))