aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:15:44 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:52 -0400
commit2785690a23a2fbf2a3b61c0b3675bf3e6e57a602 (patch)
treee2dd7da24aee5d7d1c11fe2abd070401c11a396b
parentdb64cb4010c43ffa0f942f932f6e0faf4ea24cab (diff)
downloadguix-2785690a23a2fbf2a3b61c0b3675bf3e6e57a602.tar
guix-2785690a23a2fbf2a3b61c0b3675bf3e6e57a602.tar.gz
gnu: Add go-github-com-chmduquesne-rollinghash-adler32.
* gnu/packages/syncthing.scm (go-github-com-chmduquesne-rollinghash-adler32): New variable.
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 2bea82f92c..94243c0cca 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1269,6 +1269,32 @@ and RFC 5389).")
(home-page "https://github.com/ccding/go-stun")
(license asl2.0))))
+(define-public go-github-com-chmduquesne-rollinghash-adler32
+ (let ((commit "043b8fdecc9816f0011a056f6d92f9a091ab63dd")
+ (revision "0"))
+ (package
+ (name "go-github-com-chmduquesne-rollinghash-adler32")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chmduquesne/rollinghash.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pc87laxgydqv03bdirfv32y9k0bdk2cwjxn28yh42nvay9p6y0k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/chmduquesne/rollinghash/adler32"
+ #:unpack-path "github.com/chmduquesne/rollinghash"))
+ (synopsis "Adler-32 rolling hash in Go")
+ (description "This package provides a Go implementation of the Adler-32
+rolling hash.")
+ (home-page "https://github.com/chmduquesne/rollinghash")
+ (license expat))))
+
(define-public go-github-com-petermattis-goid
(let ((commit "3db12ebb2a599ba4a96bea1c17b61c2f78a40e02")
(revision "0"))