aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 23:35:38 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:48 -0400
commit1a4795f9d0bb922a896820c5679686e4be41e21c (patch)
treeba664748d3b07cfe28025388d49f5d2c4441a4d4
parent6bc1eb1159f72e7285c57b1e25fcc466b059fcaf (diff)
downloadguix-1a4795f9d0bb922a896820c5679686e4be41e21c.tar
guix-1a4795f9d0bb922a896820c5679686e4be41e21c.tar.gz
gnu: Add go-github-com-rcrowley-go-metrics.
* gnu/packages/syncthing.scm (go-github-com-rcrowley-go-metrics): New variable.
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index f5694580b7..5b597f1c41 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -489,6 +489,32 @@ higher-level API for doing so.")
(home-page "https://github.com/stathat/go")
(license expat))))
+(define-public go-github-com-rcrowley-go-metrics
+ (let ((commit "1f30fe9094a513ce4c700b9a54458bbb0c96996c")
+ (revision "0"))
+ (package
+ (name "go-github-com-rcrowley-go-metrics")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rcrowley/go-metrics")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hvbiaq4b6dqgjz6jkkxglfh9gf71zin6qsg508sh0r0ixfavrzj"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/rcrowley/go-metrics"))
+ (propagated-inputs
+ `(("go-github-com-stathat-go" ,go-github-com-stathat-go)))
+ (synopsis "Go port of Coda Hale's Metrics library")
+ (description "This package provides a Go implementation of Coda Hale's
+Metrics library.")
+ (home-page "https://github.com/rcrowley/go-metrics")
+ (license bsd-2))))
+
(define-public go-golang-org-x-sys-unix
(let ((commit "f3918c30c5c2cb527c0b071a27c35120a6c0719a")
(revision "0"))