aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 01:08:54 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:47 -0400
commit0921b23014937639c51d25b03aa2f1210c1fe5de (patch)
tree3f78f5a3e00b7bd0e62403588eb8c15a8d62854b
parenta57778f58526ce6f147b17e6c4196b7d247e1f43 (diff)
downloadguix-0921b23014937639c51d25b03aa2f1210c1fe5de.tar
guix-0921b23014937639c51d25b03aa2f1210c1fe5de.tar.gz
gnu: Add go-github-com-oschwald-geoip2-golang.
* gnu/packages/syncthing.scm (go-github-com-oschwald-geoip2-golang): New variable.
-rw-r--r--gnu/packages/syncthing.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 0cc08db63d..d20a646a44 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -409,6 +409,35 @@ architectures.")
(home-page "https://github.com/minio/sha256-simd")
(license asl2.0))))
+(define-public go-github-com-oschwald-geoip2-golang
+ (let ((commit "0fd242da7906550802871efe101abfdb1cc550a8")
+ (revision "0"))
+ (package
+ (name "go-github-com-oschwald-geoip2-golang")
+ (version (git-version "0.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oschwald/geoip2-golang")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0kglnix0r5sjkk346ip30l7dwq1gv2g4wjy2cjmgjvb8x778hnww"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ `(("go-github-com-oschwald-maxminddb-golang"
+ ,go-github-com-oschwald-maxminddb-golang)
+ ("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
+ (arguments
+ `(#:import-path "github.com/oschwald/geoip2-golang"
+ #:tests? #f)) ; Requires some unpackaged software and test data
+ (synopsis "MaxMind GeoIP2 reader")
+ (description "This packages provides a library for reading MaxMind
+GeoLite2 and GeoIP2 databases in Go.")
+ (home-page "https://github.com/oschwald/geoip2-golang")
+ (license isc))))
+
(define-public go-github-com-oschwald-maxminddb-golang
(let ((commit "697da8075d2061aa8ed639346443f5d3e8c80b30")
(revision "0"))