aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:50:55 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:45 -0400
commit07e88fc63b3a4e92a943491f7aaa97dd7da56180 (patch)
tree27aa96d0e22e23f701bd25304a5ff760796a3ade
parent4d93ebb31363bbe5a1a6ac06772863a9c36fb4c2 (diff)
downloadguix-07e88fc63b3a4e92a943491f7aaa97dd7da56180.tar
guix-07e88fc63b3a4e92a943491f7aaa97dd7da56180.tar.gz
gnu: Add go-github-com-gogo-protobuf-protoc-gen-gogo.
* gnu/packages/syncthing.scm (go-github-com-gogo-protobuf-protoc-gen-gogo): New variable.
-rw-r--r--gnu/packages/syncthing.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index cd78e22dee..4061ee3e6f 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -187,3 +187,36 @@ structs in the Go programming language.")
(description "This packages provides a Go implementation of globs.")
(home-page "https://github.com/gobwas/glob")
(license expat))))
+
+(define-public go-github-com-gogo-protobuf-protoc-gen-gogo
+ (let ((commit "efccd33a0c20aa078705571d5ddbfa14c8395a63")
+ (revision "0"))
+ (package
+ (name "go-github-com-gogo-protobuf-protoc-gen-gogo")
+ (version (git-version "0.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gogo/protobuf")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09kfa3aqmhh7p0rc6wd4fw5cjccidsk9vgcy13albv0g8vnbmmgw"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/gogo/protobuf/protoc-gen-gogo"
+ #:unpack-path "github.com/gogo/protobuf"))
+ (synopsis "Protocol Buffers for Go with Gadgets")
+ (description "Gogoprotobuf is a fork of golang/protobuf with extra code
+generation features. This code generation is used to achieve:
+@itemize
+@item fast marshalling and unmarshalling
+@item more canonical Go structures
+@item goprotobuf compatibility
+@item less typing by optionally generating extra helper code
+@item peace of mind by optionally generating test and benchmark code
+@item other serialization formats
+@end itemize")
+ (home-page "https://github.com/gogo/protobuf")
+ (license bsd-3))))