aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-07-30 21:02:35 -0400
committerKei Kebreau <kkebreau@posteo.net>2017-09-04 00:10:59 -0400
commitd10092b849153dc27cfed0a9601fde6c7bdec918 (patch)
tree9c098d3591b62948335449d6f18f755f8a0f0f9e
parent100b216d8a4218daec4a79024d62d54b52dc07be (diff)
downloadguix-d10092b849153dc27cfed0a9601fde6c7bdec918.tar
guix-d10092b849153dc27cfed0a9601fde6c7bdec918.tar.gz
gnu: Put autoconf-related phases immediately after the 'unpack phase.
* gnu/packages/audio.scm (audacity, rtmidi)[arguments]: Correct phases accordingly. * gnu/packages/bioinformatics.scm (mash, seek, vsearch, emboss, htslib-for-sambamba)[arguments]: Likewise. * gnu/packages/ci.scm (cuirass)[arguments]: Likewise. * gnu/packages/compression.scm (minizip, xdelta)[arguments]: Likewise. * gnu/packages/cpp.scm (libzen)[arguments]: Likewise. * gnu/packages/crypto.scm (opendht)[arguments]: Likewise. * gnu/packages/databases.scm (4store, mdbtools)[arguments]: Likewise. * gnu/packages/debug.scm (stress-make)[arguments]: Likewise. * gnu/packages/dns.scm (dnscrypt-proxy, dnscrypt-wrapper)[arguments]: Likewise. * gnu/packages/emacs.scm (emacs-pdf-tools)[arguments]: Likewise. * gnu/packages/embedded.scm (libjaylink, openocd)[arguments]: Likewise. * gnu/packages/engineering.scm (gerbv)[arguments]: Likewise. * gnu/packages/erlang.scm (erlang)[arguments]: Likewise. * gnu/packages/ftp.scm (weex)[arguments]: Likewise. * gnu/packages/gnome.scm (dia)[arguments]: Likewise. * gnu/packages/gnunet.scm (gnurl, guile-gnunet)[arguments]: Likewise. * gnu/packages/gtk.scm (guile-rsvg, graphene)[arguments]: Likewise. * gnu/packages/guile.scm (guildhall, guile-ics, guile-sqlite3)[arguments]: Likewise. * gnu/packages/ibus.scm (ibus-libpinyin)[arguments]: Likewise. * gnu/packages/irc.scm (weechat)[arguments]: Likewise. * gnu/packages/java.scm (classpath-devel)[arguments]: Likewise. * gnu/packages/libreoffice.scm (libetonyek)[arguments]: Likewise. * gnu/packages/libusb.scm (hidapi)[arguments]: Likewise. * gnu/packages/linux.scm (gpm)[arguments]: Likewise. * gnu/packages/logging.scm (glog)[arguments]: Likewise. * gnu/packages/machine-learning.scm (ghmm)[arguments]: Likewise. * gnu/packages/mail.scm (dovecot-trees, dovecot-libsodium-plugin, esmtp) [arguments]: Likewise. * gnu/packages/messaging.scm (freetalk, libmesode, libstrophe)[arguments]: Likewise. * gnu/packages/microcom.scm (microcom)[arguments]: Likewise. * gnu/packages/ocaml.scm (ocaml-ssl)[arguments]: Likewise. * gnu/packages/parallel.scm (slurm)[arguments]: Likewise. * gnu/packages/pdf.scm (libharu)[arguments]: Likewise. * gnu/packages/samba.scm (cifs-utils)[arguments]: Likewise. * gnu/packages/serialization.scm (msgpack)[arguments]: Likewise. * gnu/packages/shells.scm (scsh)[arguments]: Likewise. * gnu/packages/telephony.scm (libiax2)[arguments]: Likewise. * gnu/packages/textutils.scm (dotconf)[arguments]: Likewise. * gnu/packages/version-control.scm (findnewest)[arguments]: Likewise. * gnu/packages/video.scm (libmediainfo, mediainfo)[arguments]: Likewise.
-rw-r--r--gnu/packages/audio.scm6
-rw-r--r--gnu/packages/bioinformatics.scm14
-rw-r--r--gnu/packages/ci.scm2
-rw-r--r--gnu/packages/compression.scm4
-rw-r--r--gnu/packages/cpp.scm6
-rw-r--r--gnu/packages/crypto.scm2
-rw-r--r--gnu/packages/databases.scm6
-rw-r--r--gnu/packages/debug.scm2
-rw-r--r--gnu/packages/dns.scm4
-rw-r--r--gnu/packages/emacs.scm2
-rw-r--r--gnu/packages/embedded.scm4
-rw-r--r--gnu/packages/engineering.scm20
-rw-r--r--gnu/packages/erlang.scm2
-rw-r--r--gnu/packages/ftp.scm2
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/gnunet.scm6
-rw-r--r--gnu/packages/gtk.scm2
-rw-r--r--gnu/packages/guile.scm16
-rw-r--r--gnu/packages/ibus.scm6
-rw-r--r--gnu/packages/irc.scm4
-rw-r--r--gnu/packages/java.scm2
-rw-r--r--gnu/packages/libreoffice.scm4
-rw-r--r--gnu/packages/libusb.scm2
-rw-r--r--gnu/packages/linux.scm2
-rw-r--r--gnu/packages/logging.scm2
-rw-r--r--gnu/packages/machine-learning.scm4
-rw-r--r--gnu/packages/mail.scm8
-rw-r--r--gnu/packages/messaging.scm2
-rw-r--r--gnu/packages/microcom.scm2
-rw-r--r--gnu/packages/ocaml.scm4
-rw-r--r--gnu/packages/parallel.scm5
-rw-r--r--gnu/packages/pdf.scm2
-rw-r--r--gnu/packages/samba.scm2
-rw-r--r--gnu/packages/serialization.scm2
-rw-r--r--gnu/packages/shells.scm2
-rw-r--r--gnu/packages/telephony.scm2
-rw-r--r--gnu/packages/textutils.scm2
-rw-r--r--gnu/packages/version-control.scm2
-rw-r--r--gnu/packages/video.scm8
39 files changed, 85 insertions, 86 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 16bca3b6b3..e27c13bed4 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -328,7 +328,7 @@ engineers, musicians, soundtrack editors and composers.")
#:phases
(modify-phases %standard-phases
;; FFmpeg is only detected if autoreconf runs.
- (add-before 'configure 'autoreconf
+ (add-after 'unpack 'autoreconf
(lambda _
(zero? (system* "autoreconf" "-vfi")))))
;; The test suite is not "well exercised" according to the developers,
@@ -1979,8 +1979,8 @@ tempo and pitch of an audio recording independently of one another.")
(arguments
`(#:tests? #f ;no "check" target
#:phases (modify-phases %standard-phases
- (add-before
- 'configure 'autoconf
+ (add-after
+ 'unpack 'autoconf
(lambda _ (zero? (system* "autoreconf" "-vfi"))))
(add-before
'build 'fix-makefile
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1f1b686c71..5e8eef4e1c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3450,7 +3450,7 @@ sequences).")
(("^#include \"kseq\\.h\"")
"#include \"htslib/kseq.h\""))
#t))
- (add-before 'configure 'autoconf
+ (add-after 'fix-includes 'autoconf
(lambda _ (zero? (system* "autoconf")))))))
(native-inputs
`(("autoconf" ,autoconf)
@@ -4486,7 +4486,7 @@ distribution, coverage uniformity, strand specificity, etc.")
"Data2DB"
"PCL2Bin")))
(modify-phases %standard-phases
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda _
(zero? (system* "bash" "gen_auto"))))
(add-after 'build 'build-additional-tools
@@ -6164,8 +6164,8 @@ track. The database is exposed as a @code{TxDb} object.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autogen
- (lambda _ (zero? (system* "autoreconf" "-vif")))))))
+ (add-after 'unpack 'autogen
+ (lambda _ (zero? (system* "autoreconf" "-vif")))))))
(inputs
`(("zlib" ,zlib)
("bzip2" ,bzip2)
@@ -8381,14 +8381,14 @@ used by @code{ensembldb}, @code{Organism.dplyr}, and other packages.")
AC_DEFINE([PLD_png], [1], [Define to 1 if PNG support is available])
AM_CONDITIONAL(AMPNG, true)"))
#t))
- (add-after 'unpack 'disable-update-check
+ (add-after 'fix-checks 'disable-update-check
(lambda _
;; At build time there is no connection to the Internet, so
;; looking for updates will not work.
(substitute* "Makefile.am"
(("\\$\\(bindir\\)/embossupdate") ""))
#t))
- (add-before 'configure 'autogen
+ (add-after 'disable-update-check 'autogen
(lambda _ (zero? (system* "autoreconf" "-vif")))))))
(inputs
`(("perl" ,perl)
@@ -9453,7 +9453,7 @@ problems in genomics, brain imaging, astrophysics, and data mining.")
(substitute-keyword-arguments (package-arguments htslib)
((#:phases phases)
`(modify-phases ,phases
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda _
(zero? (system* "autoreconf" "-vif"))))))))
(native-inputs
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index d936c8fa10..c449754be8 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -216,7 +216,7 @@ their dependencies.")
(substitute* "Makefile.am"
(("tests/repo.scm \\\\") "\\"))
#t))
- (add-before 'configure 'bootstrap
+ (add-after 'disable-repo-tests 'bootstrap
(lambda _ (zero? (system* "sh" "bootstrap"))))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index bc10536766..a6758e9471 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -114,7 +114,7 @@ in compression.")
(modify-phases %standard-phases
(add-after 'unpack 'enter-source
(lambda _ (chdir "contrib/minizip") #t))
- (add-before 'configure 'autoreconf
+ (add-after 'enter-source 'autoreconf
(lambda _
(zero? (system* "autoreconf" "-vif")))))))
(native-inputs
@@ -976,7 +976,7 @@ respectively, based on the reference implementation from Google.")
(modify-phases %standard-phases
(add-after 'unpack 'enter-build-directory
(lambda _ (chdir "xdelta3")))
- (add-before 'configure 'autoconf
+ (add-after 'enter-build-directory 'autoconf
(lambda _ (zero? (system* "autoreconf" "-vfi")))))))
(home-page "http://xdelta.com")
(synopsis "Delta encoder for binary files")
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index da192553a5..5ad9fd33bc 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -45,12 +45,12 @@
'(#:phases
;; build scripts not in root of archive
(modify-phases %standard-phases
- (add-before 'configure 'pre-configure
+ (add-after 'unpack 'pre-configure
(lambda _
(chdir "Project/GNU/Library")))
- (add-before 'configure 'autogen
+ (add-after 'pre-configure 'autogen
(lambda _
- (zero? (system* "./autogen.sh")))))))
+ (zero? (system* "sh" "autogen.sh")))))))
(home-page "https://github.com/MediaArea/ZenLib")
(synopsis "C++ utility library")
(description "ZenLib is a C++ utility library. It includes classes for handling
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 0a05a10698..1783ae0945 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -161,7 +161,7 @@ OpenBSD tool of the same name.")
(arguments
`(#:configure-flags '("--disable-tools" "--disable-python")
#:phases (modify-phases %standard-phases
- (add-before 'configure 'autoconf
+ (add-after 'unpack 'autoconf
(lambda _
(zero? (system* "autoreconf" "-vfi")))))))
(home-page "https://github.com/savoirfairelinux/opendht/")
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 93d59837bb..c6a9ff5bd6 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -115,9 +115,9 @@
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'generate-configure
+ (add-after 'unpack 'generate-configure
(lambda _
- (zero? (system* "./autogen.sh")))))))
+ (zero? (system* "sh" "autogen.sh")))))))
;; http://www.4store.org has been down for a while now.
(home-page "https://github.com/garlik/4store")
(synopsis "Clustered RDF storage and query engine")
@@ -1563,7 +1563,7 @@ for ODBC.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autoreconf
+ (add-after 'unpack 'autoreconf
(lambda _
(zero? (system* "autoreconf" "-vfi")))))))
(home-page "http://mdbtools.sourceforge.net/")
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 0fc1f513ba..43bfd9e514 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -319,7 +319,7 @@ down the road.")
(add-before 'configure 'repack-make
(lambda _
(zero? (system* "tar" "cJf" "./make.tar.xz" ,make-dir))))
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda _
(zero? (system* "autoreconf" "-vfi"))))))))
(home-page "https://github.com/losalamos/stress-make")
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 702ed011f4..1716ca748c 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -181,7 +181,7 @@ high-volume and high-reliability applications. The name BIND stands for
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autoreconf
+ (add-after 'unpack 'autoreconf
(lambda _
;; Re-generate build files due to unbundling ltdl.
;; TODO: Prevent generating new libltdl and building it.
@@ -229,7 +229,7 @@ servers is included, and an up-to-date version is available at
#:tests? #f
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'create-configure
+ (add-after 'unpack 'create-configure
(lambda _
(zero? (system* "make" "configure")))))))
(native-inputs
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 8955313e59..b3d5fc97e2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1273,7 +1273,7 @@ single buffer.")
;; Build server side using 'gnu-build-system'.
(add-after 'unpack 'enter-server-dir
(lambda _ (chdir "server") #t))
- (add-before 'configure 'autogen
+ (add-after 'enter-server-dir 'autogen
(lambda _
(zero? (system* "bash" "autogen.sh"))))
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 5e51fe2d01..2a298dca9d 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -316,7 +316,7 @@ languages are C and C++.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autoreconf
+ (add-after 'unpack 'autoreconf
(lambda _
(zero? (system* "autoreconf" "-vfi")))))))
(home-page "http://repo.or.cz/w/libjaylink.git")
@@ -400,7 +400,7 @@ language.")
"presto" "openjtag")))
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autoreconf
+ (add-after 'unpack 'autoreconf
(lambda _
(zero? (system* "autoreconf" "-vfi")))))))
(home-page "http://openocd.org")
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index c4afe5ff95..0955bb4ae3 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -485,16 +485,16 @@ ready for production.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autoconf
- (lambda _
- ;; Build rules contain references to Russian translation, but the
- ;; needed files are missing; see
- ;; http://sourceforge.net/p/gerbv/bugs/174/
- (delete-file "po/LINGUAS")
- (substitute* "man/Makefile.am"
- (("PO_FILES= gerbv.ru.1.in.po") "")
- (("man_MANS = gerbv.1 gerbv.ru.1") "man_MANS = gerbv.1"))
- (zero? (system* "autoreconf" "-vfi")))))))
+ (add-after 'unpack 'autoconf
+ (lambda _
+ ;; Build rules contain references to Russian translation, but the
+ ;; needed files are missing; see
+ ;; http://sourceforge.net/p/gerbv/bugs/174/
+ (delete-file "po/LINGUAS")
+ (substitute* "man/Makefile.am"
+ (("PO_FILES= gerbv.ru.1.in.po") "")
+ (("man_MANS = gerbv.1 gerbv.ru.1") "man_MANS = gerbv.1"))
+ (zero? (system* "autoreconf" "-vfi")))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index a400e712d5..cf4d7a5955 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -143,7 +143,7 @@
(add-before 'configure 'set-erl-top
(lambda _
(setenv "ERL_TOP" (getcwd))))
- (add-before 'configure 'autoconf
+ (add-after 'patch-source-env 'autoconf
(lambda _ (zero? (system* "./otp_build" "autoconf"))))
(add-after 'install 'patch-erl
;; This only works after install.
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index bbdb4e410b..63a4054617 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -159,7 +159,7 @@ FTP browser, as well as non-interactive commands such as 'ncftpput' and
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda _ (zero? (system* "autoreconf" "-vfi")))))))
(home-page "http://weex.sourceforge.net/")
(synopsis "Non-interactive client for FTP synchronization")
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 43547961bf..5c94ceb036 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -312,7 +312,7 @@ either on a local, or remote machine via a number of methods.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'run-autogen
+ (add-after 'unpack 'run-autogen
(lambda _
(system* "sh" "autogen.sh"))))))
(home-page "https://wiki.gnome.org/Apps/Dia")
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 837f9a21b6..426d0eec49 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -234,10 +234,10 @@ and support for SSL3 and TLS.")
(rename-file (string-append out "/share/man/man3")
(string-append doc "/share/man/man3"))
#t)))
- (add-before 'configure 'autoconf
+ (add-after 'unpack 'autoconf
;; Clear artifacts left (shebangs) from release preparation.
(lambda _
- (zero? (system* "./buildconf"))))
+ (zero? (system* "sh" "buildconf"))))
(replace 'check
(lambda _
;; It is unclear why test1026 fails, however the content of it
@@ -345,7 +345,7 @@ kinds of basic applications for the foundation of a GNU internet.")
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda _
(zero? (system* "autoreconf" "-vfi")))))))
(native-inputs `(("pkg-config" ,pkg-config)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 74f7b70ffe..1ea051bfb0 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -838,7 +838,7 @@ exceptions, macros, and a dynamic programming environment.")
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda _
(zero? (system* "autoreconf" "-vfi")))))))
(native-inputs `(("pkg-config" ,pkg-config)
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 6dacc472a8..0bcc524ed7 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -365,7 +365,7 @@ AM_SCM_LOG_FLAGS = --no-auto-compile -s")
;; reasons. It does not fail when run outside of Guix.
(("tests/database.scm") ""))
#t))
- (add-before 'configure 'autogen
+ (add-after 'fix-bug-22 'autogen
(lambda _
(zero? (system* "sh" "autogen.sh")))))))
(inputs
@@ -654,12 +654,12 @@ format is also supported.")
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'configure 'autoreconf
- (lambda _
- ;; Repository comes with a broken symlink
- (delete-file "README")
- (symlink "README.org" "README")
- (zero? (system* "autoreconf" "-fi")))))))
+ (add-after 'unpack 'autoreconf
+ (lambda _
+ ;; Repository comes with a broken symlink
+ (delete-file "README")
+ (symlink "README.org" "README")
+ (zero? (system* "autoreconf" "-fi")))))))
(native-inputs
`(("autoconf" ,(autoconf-wrapper))
("automake" ,automake)
@@ -1126,7 +1126,7 @@ Guile's foreign function interface.")
("sqlite" ,sqlite)))
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'configure 'autoreconf
+ (add-after 'unpack 'autoreconf
(lambda _
(zero? (system* "autoreconf" "-vfi"))))
(add-before 'build 'set-sqlite3-file-name
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 2200b6663d..7bbf2d6d7d 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -148,9 +148,9 @@ may also simplify input method development.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autogen
- (lambda _ (and (zero? (system* "intltoolize"))
- (zero? (system* "autoreconf" "-vif")))))
+ (add-after 'unpack 'autogen
+ (lambda _ (and (zero? (system* "intltoolize"))
+ (zero? (system* "autoreconf" "-vif")))))
(add-after 'wrap-program 'wrap-with-additional-paths
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make sure 'ibus-setup-libpinyin' runs with the correct
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 0f68cc532a..2e8d3d4573 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -180,9 +180,9 @@ SILC and ICB protocols via plugins.")
"--with-tclconfig="
(assoc-ref %build-inputs "tcl") "/lib"))
#:phases (modify-phases %standard-phases
- (add-before 'configure 'autogen
+ (add-after 'unpack 'autogen
(lambda _
- (zero? (system* "./autogen.sh"))))
+ (zero? (system* "sh" "autogen.sh"))))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index fe43d01332..028fe06631 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -685,7 +685,7 @@ the standard javac executable. The tool runs on JamVM instead of SableVM.")))
"--disable-gjdoc")
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'bootstrap
+ (add-after 'remove-unsupported-anootations 'bootstrap
(lambda _
(zero? (system* "autoreconf" "-vif"))))
(add-after 'unpack 'remove-unsupported-annotations
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index cca222b1f8..d1e2e2e6e3 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -364,8 +364,8 @@ CorelDRAW documents of all versions.")
(arguments
`(#:configure-flags '("--with-mdds=1.2")
#:phases (modify-phases %standard-phases
- (add-before 'configure 'autoreconf
- (lambda _ (system* "autoreconf"))))))
+ (add-after 'unpack 'autoreconf
+ (lambda _ (system* "autoreconf"))))))
(native-inputs
`(("cppunit" ,cppunit)
("doxygen" ,doxygen)
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index ed97ed9de7..f1d75220a9 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -332,7 +332,7 @@ devices.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda _
(zero? (system* "autoreconf" "-vfi")))))))
(inputs
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 714c631fb1..dfb3dec2b9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3122,7 +3122,7 @@ write access to exFAT devices.")
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda _
;; The tarball was not generated with 'make dist' so we
;; need to bootstrap things ourselves.
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index b4f7caf56a..648a07e4c4 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -75,7 +75,7 @@ staying as close to their API as is reasonable.")
("libtool" ,libtool)))
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'configure 'add-automake-files
+ (add-after 'unpack 'add-automake-files
(lambda _
;; The 'test-driver' file is a dangling symlink to
;; /usr/share/automake; replace it. We can't just run
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index c5132faf58..58b47dacd1 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -190,9 +190,9 @@ classification.")
"@unittest.skip(\"Disabled by Guix\")\n"
line)))
#t))
- (add-before 'configure 'autogen
+ (add-after 'disable-broken-tests 'autogen
(lambda _
- (zero? (system* "bash" "./autogen.sh")))))))
+ (zero? (system* "bash" "autogen.sh")))))))
(inputs
`(("python" ,python-2) ; only Python 2 is supported
("libxml2" ,libxml2)))
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index fe040a1180..2a759c3d2e 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1169,9 +1169,9 @@ It supports mbox/Maildir and its own dbox/mdbox formats.")
"/lib/dovecot"))
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autogen
+ (add-after 'unpack 'autogen
(lambda _
- (zero? (system* "./autogen.sh")))))))
+ (zero? (system* "sh" "autogen.sh")))))))
(home-page "https://0xacab.org/riseuplabs/trees")
(synopsis "NaCL-based Dovecot email storage encryption plugin")
(description
@@ -1225,9 +1225,9 @@ using lidsodium sealed boxes.
"/lib/dovecot"))
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autogen
+ (add-after 'unpack 'autogen
(lambda _
- (zero? (system* "./autogen.sh")))))))
+ (zero? (system* "sh" "autogen.sh")))))))
(home-page "https://github.com/LuckyFellow/dovecot-libsodium-plugin")
(synopsis "Libsodium password hashing schemes plugin for Dovecot")
(description
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index c69bd8b101..52ca4bef79 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1209,7 +1209,7 @@ support, and more.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autogen
+ (add-after 'unpack 'autogen
(lambda _
(zero? (system* "sh" "autogen.sh"))))
;; For 'system' commands in Scheme code.
diff --git a/gnu/packages/microcom.scm b/gnu/packages/microcom.scm
index aa42e99213..dcb864808f 100644
--- a/gnu/packages/microcom.scm
+++ b/gnu/packages/microcom.scm
@@ -42,7 +42,7 @@
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda _
(zero? (system* "autoreconf" "-i")))))))
(inputs `(("readline" ,readline)))
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2597775bf7..700c5698ed 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1631,9 +1631,9 @@ lets the client choose the concrete timeline.")
#:make-flags (list "OCAMLFIND_LDCONF=ignore")
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda* (#:key #:allow-other-keys)
- (system* "./bootstrap")
+ (system* "sh" "bootstrap")
(substitute* "src/OCamlMakefile"
(("/bin/sh") (which "bash")))
(substitute* "configure"
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index db04a5704e..5101838d26 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -136,9 +136,8 @@ and they are executed on lists of files, hosts, users or other items.")
(string-append "--with-ssl=" (assoc-ref %build-inputs "openssl")))
#:phases
(modify-phases %standard-phases
- (add-before
- 'configure 'autogen
- (lambda _ (zero? (system* "autoconf"))))))) ; configure.ac was patched
+ (add-after 'unpack 'autogen
+ (lambda _ (zero? (system* "autoconf"))))))) ; configure.ac was patched
(home-page "http://slurm.schedmd.com/")
(synopsis "Workload manager for cluster computing")
(description
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 0993543c20..5e52d87ca5 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -254,7 +254,7 @@ Poppler PDF rendering library.")
(assoc-ref %build-inputs "libpng")))
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autogen
+ (add-after 'unpack 'autogen
(lambda _ (zero? (system* "autoreconf" "-vif")))))))
(inputs
`(("zlib" ,zlib)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 116d7f60ec..1fc4994ab3 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -71,7 +71,7 @@
`(#:phases
(modify-phases %standard-phases
;; The 6.7 tarball is missing ‘install.sh’. Create it.
- (add-before 'configure 'autoreconf
+ (add-after 'unpack 'autoreconf
(lambda _
(zero? (system* "autoreconf" "-i"))))
(add-before 'configure 'set-root-sbin
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 54ccbf7c79..1866926129 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -127,7 +127,7 @@ such as compact binary encodings, XML, or JSON.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autoconf
+ (add-after 'unpack 'autoconf
(lambda _
(system* "autoreconf" "-vfi"))))))
(home-page "http://www.msgpack.org")
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 09a6c3a03f..f03d7c4a9d 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -430,7 +430,7 @@ use of experts and novices alike.")
(delete-file-recursively "rx")
(symlink rxpath "rx"))
#t))
- (add-before 'configure 'autoreconf
+ (add-after 'unpack 'autoreconf
(lambda _
(zero? (system* "autoreconf")))))))
(inputs
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index c3bf203602..5751015260 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -272,7 +272,7 @@ and a supporting cryptographic kernel.")
("libtool" ,libtool)))
(arguments
`(#:phases (modify-phases %standard-phases
- (add-before 'configure 'autoconf
+ (add-after 'unpack 'autoconf
(lambda _
(zero? (system* "autoreconf" "-vfi")))))))
(home-page "https://gitlab.savoirfairelinux.com/sflphone/libiax2")
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 70b057ffd3..3359ab4845 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -579,7 +579,7 @@ categories.")
`(#:tests? #f ; FIXME maketest.sh does not work.
#:phases
(modify-phases %standard-phases
- (add-before 'configure 'autoreconf
+ (add-after 'unpack 'autoreconf
(lambda _
(zero? (system* "autoreconf" "-vif")))))))
(native-inputs
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 36a6b7cd18..0657df67a1 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1263,7 +1263,7 @@ output of the 'git' command.")
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-before 'configure 'bootstrap
+ (add-after 'unpack 'bootstrap
(lambda _
(zero? (system* "autoreconf" "-vfi")))))))
(native-inputs `(("autoconf" ,autoconf)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4eb6b8b6e8..3924e93f96 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2253,9 +2253,9 @@ practically any type of media.")
(add-before 'configure 'pre-configure
(lambda _
(chdir "Project/GNU/Library")))
- (add-before 'configure 'autogen
+ (add-after 'unpack 'autogen
(lambda _
- (zero? (system* "./autogen.sh")))))))
+ (zero? (system* "sh" "autogen.sh")))))))
(home-page "https://mediaarea.net/en/MediaInfo")
(synopsis "Library for retrieving media metadata")
(description "MediaInfo is a library used for retrieving technical
@@ -2311,9 +2311,9 @@ MPEG-2, MPEG-4, DVD (VOB)...
(add-before 'configure 'pre-configure
(lambda _
(chdir "Project/GNU/CLI")))
- (add-before 'configure 'autogen
+ (add-after 'unpack 'autogen
(lambda _
- (zero? (system* "./autogen.sh")))))))
+ (zero? (system* "sh" "autogen.sh")))))))
(home-page "https://mediaarea.net/en/MediaInfo")
(synopsis "Utility for reading media metadata")
(description "MediaInfo is a utility used for retrieving technical