aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-09-01 14:39:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-09-01 15:11:58 +0200
commitc4a4ef39edee3105c35a667dd02efa524fadf798 (patch)
treed4ee8a220103326ad0c05197e24f23990df7e094
parentdb2e43863ca3ef5beb8eb712ce4ae7dfcfe83e2a (diff)
downloadguix-c4a4ef39edee3105c35a667dd02efa524fadf798.tar
guix-c4a4ef39edee3105c35a667dd02efa524fadf798.tar.gz
gnu: Add r-tidyselect.
* gnu/packages/statistics.scm (r-tidyselect): New variable.
-rw-r--r--gnu/packages/statistics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index f800e1c7d2..100dcbd80f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3557,6 +3557,32 @@ perceived by readers with the most common form of color blindness. This is
the 'lite' version of the more complete @code{viridis} package.")
(license license:expat)))
+(define-public r-tidyselect
+ (package
+ (name "r-tidyselect")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tidyselect" version))
+ (sha256
+ (base32
+ "1h10qc5bxk5v0zhmip3gwnzy50fs2gbdvcg2163is0k9a8rifq9r"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-glue" ,r-glue)
+ ("r-purrr" ,r-purrr)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rlang" ,r-rlang)))
+ (home-page "http://cran.r-project.org/web/packages/tidyselect")
+ (synopsis "Select from a set of strings")
+ (description
+ "This package provides a backend for the selecting functions of the
+tidyverse. It makes it easy to implement select-like functions in your own
+packages in a way that is consistent with other tidyverse interfaces for
+selection.")
+ (license license:gpl3)))
+
(define-public r-tidyr
(package
(name "r-tidyr")