aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-08-30 09:41:26 +0000
committerLudovic Courtès <ludo@gnu.org>2017-09-01 10:34:36 +0200
commitab966b8f61731416bf21c76fa9707617198d06db (patch)
tree764e604324423bc7af365e1afb3a94c6fe5b464a
parent5c5ae46c00fd553c6fd23aeba1961e201f6555c7 (diff)
downloadguix-ab966b8f61731416bf21c76fa9707617198d06db.tar
guix-ab966b8f61731416bf21c76fa9707617198d06db.tar.gz
gnu: Add emacs-2048-game.
* gnu/packages/emacs.scm (emacs-2048-game): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3a4f9d327f..9852265712 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
;;; Copyright © 2016, 2017 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2016, 2017 ng0 <ng0@infotropique.org>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2017 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
@@ -2604,6 +2604,27 @@ transparent background. If you load it from a GUI, it will default to a
dark background.")
(license license:gpl3+)))
+(define-public emacs-2048-game
+ (package
+ (name "emacs-2048-game")
+ (version "20151026.1233")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://melpa.org/packages/2048-game-"
+ version ".el"))
+ (sha256
+ (base32
+ "0gy2pvz79whpavp4jmz8h9krzn7brmvv3diixi1d4w51pcdvaldd"))))
+ (build-system emacs-build-system)
+ (home-page "https://bitbucket.org/zck/2048.el")
+ (synopsis "Implementation of the game 2048 in Emacs Lisp")
+ (description
+ "This program is an implementation of 2048 for Emacs.
+The goal of this game is to create a tile with value 2048. The size of the
+board and goal value can be customized.")
+ (license license:gpl3+)))
+
(define-public emacs-smartparens
(package
(name "emacs-smartparens")